NYOJ 15 括号匹配(二) POJ 2955 Brackets(区间dp)

括号匹配(二)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 6
描述
给你一个字符串,里面只包含"(",")","[","]"四种符号,请问你需要至少添加多少个括号才能使这些括号匹配起来。
如:
[]是匹配的
([])[]是匹配的
((]是不匹配的
([)]是不匹配的
输入
第一行输入一个正整数N,表示测试数据组数(N<=10)
每组测试数据都只有一行,是一个字符串S,S中只包含以上所说的四种字符,S的长度不超过100
输出
对于每组测试数据都输出一个正整数,表示最少需要添加的括号的数量。每组测试输出占一行
样例输入
4
[]
([])[]
((]
([)]
样例输出
0
0
3
2
 
   
思路: 区间dp 粘一下一位大神的解释吧。

描述:给出一串的只有‘(’ ‘)’  '[‘  ']'四种括号组成的串,让你求解需要最少添加括号数让串中的所有括号完全匹配。

分析:我们求出这个串的最大匹配,然后串的总长度-最大匹配就是答案。

方法1:首先能想到的是转化成LCS(最长公共子序列),枚举中间点,求所有的LCS中的最大值 * 2就是最大匹配。但是复杂度较高,光LCS一次就O(n^2)的复杂度。

方法2:

首先考虑怎么样定义dp让它满足具有通过子结构来求解、

定义dp [ i ] [ j ] 为串中第 i 个到第 j 个括号的最大匹配数目

那么我们假如知道了 i 到 j 区间的最大匹配,那么i+1到 j+1区间的是不是就可以很简单的得到。

那么 假如第 i 个和第 j 个是一对匹配的括号那么dp [ i ] [ j ] = dp [ i+1 ] [ j-1 ] + 2 ;

那么我们只需要从小到大枚举所有 i 和 j 中间的括号数目,然后满足匹配就用上面式子dp,然后每次更新dp [ i ] [ j ]为最大值即可。

更新最大值的方法是枚举 i 和 j 的中间值,然后让 dp[ i ] [ j ] = max ( dp [ i ] [ j ] , dp [ i ] [ f ] + dp [ f+1 ] [ j ] ) ;

dp[i][j]   表示的是从i到j的最大匹配数。


用字符串的长度减去最大匹配数,就是需要的字符个数。


代码: 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 105

using namespace std;

int dp[N][N];
char s[N];

int main()
{
	int cas;
	int i,d,k,j;
	scanf("%d",&cas);
	while(cas--)
	{
		scanf("%s",s);
		int len=strlen(s);
		memset(dp,0,sizeof(dp));
		for(i=0;i<len-1;i++)
		{
			if(s[i]=='('&&s[i+1]==')')
			{
				dp[i][i+1]=2;
			}
			else if(s[i]=='['&&s[i+1]==']')
			{
				dp[i][i+1]=2;
			}
		}
		for(d=1;d<len;d++)
		{
			for(i=0;i<=len-d;i++)
			{
				j=i+d;
				if((s[i]=='('&&s[j]==')')||s[i]=='['&&s[j]==']')
				{
					dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
				}
				for(k=i;k<j;k++)
				{
					dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
				}
			}
		}
		printf("%d\n",len-dp[0][len-1]);
	}
	return 0;
}


Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9084 Accepted: 4866

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
题意: 找出最大匹配数。


比上边更简单。


代码 : 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 105

using namespace std;

int dp[N][N];
char s[N];

int main()
{
	int cas;
	int i,d,k,j;
	while(~scanf("%s",s))
	{
		if(strcmp(s,"end")==0) break;
		int len=strlen(s);
		memset(dp,0,sizeof(dp));
		for(i=0;i<len-1;i++)
		{
			if(s[i]=='('&&s[i+1]==')')
			{
				dp[i][i+1]=2;
			}
			else if(s[i]=='['&&s[i+1]==']')
			{
				dp[i][i+1]=2;
			}
		}
		for(d=1;d<len;d++)
		{
			for(i=0;i<=len-d;i++)
			{
				j=i+d;
				if((s[i]=='('&&s[j]==')')||s[i]=='['&&s[j]==']')
				{
					dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
				}
				for(k=i;k<j;k++)
				{
					dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
				}
			}
		}
		printf("%d\n",dp[0][len-1]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值