HDU 3555(数位dp)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 20122    Accepted Submission(s): 7508


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
题 意 :找出含有49 的数的个数。
思 路: 数位dp的模板题。
代码1:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 22

using namespace std;

long long dp[N][10];//dp[i][j]表示i位数以j开头中不含有49 的个数。
int num[N];

long long dfs(int pos,int pre,int lim)
{
	if(pos<=0) return 1;
	if(!lim&&dp[pos][pre]!=-1) return dp[pos][pre];
	
	int end=lim?num[pos]:9;
	long long fin=0;
	for(int i=0;i<=end;i++)
	{
		if(pre==4&&i==9) continue;
		fin+=dfs(pos-1,i,lim&&i==end);
	}
	if(!lim) dp[pos][pre]=fin;
	return fin;
	
}

void solve(long long x)
{
	long long xx=x;
	int len=0;
	while(x)
	{
		num[++len]=x%10;
		x/=10;
	}
	long long fin=dfs(len,0,1);
	printf("%lld\n",xx-fin+1);//加1   是因为将 0 算入dp其中。
	return ;
}


int main()
{
	int t;
	scanf("%d",&t);
	memset(dp,-1,sizeof(dp));
	while(t--)
	{
		long long n;
		scanf("%lld",&n);
		solve(n);
	}
	return 0;
}

代码2;

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>

using namespace std;

long long dp[22][10][2];//dp[i][j][k]表示i位数中以j开头 中 type表示数是否含有 49 。
int num[22];

long long dfs(int pos,int pre,int type,int lim)
{
	if(pos<=0) return type;
	if(!lim&&dp[pos][pre][type]!=-1) return dp[pos][pre][type];
	int end=lim?num[pos]:9;
	long long fin=0;
	for(int i=0;i<=end;i++)
	{
		fin+=dfs(pos-1,i,type||pre==4&&i==9,lim&&i==end);
	}
	if(!lim) dp[pos][pre][type]=fin;
	
	return fin;
}

void solve(long long x)
{
	int len=0;
	while(x)
	{
		num[++len]=x%10;
		x/=10;
	}
	long long fin=dfs(len,0,0,1);
	printf("%lld\n",fin);
	return ;
}

int main()
{
	int t;
	scanf("%d",&t);
	memset(dp,-1,sizeof(dp));
	while(t--)
	{
		long long n;
		scanf("%lld",&n);
		solve(n);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值