HDU 3652 (数位dp)

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7127    Accepted Submission(s): 4166


Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
  
  
13 100 200 1000
 

Sample Output
  
  
1 1 2 2
题意: 你的任务是找出含有 13 并且能被 13整除的数的个数。
 dp[i][mod][type][pre]:i:处理的数位,mod:该数对13取模以后的值,type:是否已经包含13,pre结尾的数 
代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>

using namespace std;

int dp[22][15][2][10];
int num[22];

int dfs(int pos,int mod,int type,int pre,int lim)
{
	//type 为 1  表示含有 13 为 0 表示不含有 13  
	if(pos<=0){
		if(type&&mod==0) return 1;//到最低位 如果mod==0 并且 有13存在  那么久返回 1。 
		else return 0;
	}
	
	if(!lim&&dp[pos][mod][type][pre]!=-1) return dp[pos][mod][type][pre];
	
	int end=lim?num[pos]:9;
	int fin=0;
	for(int i=0;i<=end;i++)
	{
		fin+=dfs(pos-1,(mod*10+i)%13,type||(pre==1&&i==3),i,lim&&i==end);//这里的(mod*10)%13  其实就是一个除法的模拟。直到除到最后一位,
		//如果mod为0  那么表示这个数可以被13整除 
	}
	if(!lim) dp[pos][mod][type][pre]=fin;
	return fin;
}

void solve(int x)
{
	int len=0;
	while(x)
	{
		num[++len]=x%10;
		x/=10;
	}
	int fin=dfs(len,0,0,0,1);
	printf("%d\n",fin);
	return ;
}

int main()
{
	int n;
	memset(dp,-1,sizeof(dp));
	while(scanf("%d",&n)!=EOF)
	{
		solve(n);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值