安卓旧库与新库

最近在搞Toolbar,在gradle中导入v7库的时候没有报错,在Activity中却无法使用库中的类,网上查了好多也没解决问题,后来在stack overflow中找到了答案。
原来是导入时androidx和android冲突。我新建项目是自动使用的是androidx,这是在高版本中才能使用,而我却手动导入com.android.support:appcompat-v7,所以就出现报错无法解析v7。
然后我就搜索旧包和新包,发现一个博主写的了,分享一下。
https://www.jianshu.com/p/1466ebefe4d0

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页