Common Subsequence(hdu 1159)

Common Subsequence

TimeLimit: 2000/1000 MS(Java/Others)    MemoryLimit: 65536/32768 K (Java/Others)
Total Submission(s):11711    AcceptedSubmission(s): 4810


Problem Description
A subsequence of a given sequence is the given sequence with someelements (possible none) left out. Given a sequence X =<x1, x2, ..., xm> another sequence Z= <z1, z2, ..., zk> is a subsequenceof X if there exists a strictly increasing sequence<i1, i2, ..., ik> of indices of Xsuch that for all j = 1,2,...,k, xij = zj. For example, Z =<a, b, f, c> is a subsequence of X =<a, b, c, f, b, c> with indexsequence <1, 2, 4, 6>. Given twosequences X and Y the problem is to find the length of themaximum-length common subsequence of X andY. 
The program input is from a text file. Each data set in the filecontains two strings representing the given sequences. Thesequences are separated by any number of white spaces. The inputdata are correct. For each set of data the program prints on thestandard output the length of the maximum-length common subsequencefrom the beginning of a separateline. 
 

Sample Input
 
  
abcfbcabfcab programming contest abcd mnp
 

Sample Output
 
  
4 20
 

Source
 

Recommend
Ignatius
 

#include<iostream>
#include <stdio.h>
#include<algorithm>
#include <string>
#include<string.h>
#include<stdlib.h>
#include <math.h>
#define MAXLEN 500
using namespace std;
void lcs(char *x,char *y,int m,int n,int c[][MAXLEN]){
    int i,j;
    for(i=0;i<m;i++)
       c[i][0]=0;
    for(i=0;i<n;i++)
       c[0][i]=0;
    for(i=1;i<=m;i++)
       for(j=1;j<=n;j++){
          if(x[i-1]==y[j-1])
              c[i][j]=c[i-1][j-1]+1;
          else if(c[i-1][j]>c[i][j-1])
              c[i][j]=c[i-1][j];
          else 
              c[i][j]=c[i][j-1];
       }
    printf("%d\n",c[m][n]);
}
int main(){
   intc[MAXLEN][MAXLEN];
    char x[MAXLEN],y[MAXLEN];
    int m,n;
    while (~scanf("%s%s",x,y)) {
       m=strlen(x);
       n=strlen(y);
       lcs(x,y,m,n,c);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值