[poj3468]树状数组,速度为线段树3倍!!

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 106188 Accepted: 33139
Case Time Limit: 2000MS
Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.

因为从来没有写过树状数组,只写得来线段树,现在也没搞懂,等几天再补充一下

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
#define ll long long int
ll a[510000],a1[510000],b[510000];
int n;
int lowbit(int x){
    return x&(-x);
}
void update(ll *arry,int x,int d){
    while(x<=n){
        arry[x] += d;
        x+=lowbit(x);
    }
}
ll query(ll *arry,int x){
   ll sum=0;
   while(x>0){
       sum+=arry[x];
       x-=lowbit(x);
   }
   return sum;
}
int main(){
    int k;
    int x,i,y,z;
    scanf("%d%d",&n,&k);
    memset(b,0,sizeof(b));
    memset(a,0,sizeof(a));
    memset(a1,0,sizeof(a1));
    for(i=1;i<=n;i++)
    {
        scanf("%d",&x);
        b[i] = b[i-1] + x;
    }
    char c;
    for(i=0;i<k;i++) {
        c=getchar();c=getchar();
        if(c=='C') {
            scanf("%d%d%d", &x, &y, &z);
            update( a, x, z );
            update( a, y+1, -z );
            update( a1, x, z*x );
            update( a1, y+1, -z*(y+1) );
        }
        else {
            scanf("%d%d", &x, &y);
            ll sum=-b[x-1]-x*query(a,x-1)+query(a1,x-1);
            sum+=b[y]+(y+1)*query(a,y)-query(a1,y);
            printf("%I64d\n",sum);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值