[bzoj2843]极地旅行社 Link-Cut-Tree

2843: 极地旅行社

Time Limit: 10 Sec   Memory Limit: 256 MB
[ Submit][ Status][ Discuss]

Description

不久之前,Mirko建立了一个旅行社,名叫“极地之梦”。这家旅行社在北极附近购买了N座冰岛,并且提供观光服
务。当地最受欢迎的当然是帝企鹅了,这些小家伙经常成群结队的游走在各个冰岛之间。Mirko的旅行社遭受一次
重大打击,以至于观光游轮已经不划算了。旅行社将在冰岛之间建造大桥,并用观光巴士来运载游客。Mirko希望
开发一个电脑程序来管理这些大桥的建造过程,以免有不可预料的错误发生。这些冰岛从1到N标号。一开始时这些
岛屿没有大桥连接,并且所有岛上的帝企鹅数量都是知道的。每座岛上的企鹅数量虽然会有所改变,但是始终在[0
, 1000]之间。你的程序需要处理以下三种命令:
1."bridge A B"——在A与B之间建立一座大桥(A与B是不同的岛屿)。由于经费限制,这项命令被接受,当且仅当
A与B不联通。若这项命令被接受,你的程序需要输出"yes",之
后会建造这座大桥。否则,你的程序需要输出"no"。
2."penguins A X"——根据可靠消息,岛屿A此时的帝企鹅数量变为X。这项命令只是用来提供信息的,你的程序不
需要回应。
3."excursion A B"——一个旅行团希望从A出发到B。若A与B连通,你的程序需要输出这个旅行团一路上所能看到的
帝企鹅数量(包括起点A与终点B),若不联通,你的程序需要输出"impossible"。

Input

第一行一个正整数N,表示冰岛的数量。
第二行N个范围[0, 1000]的整数,为每座岛屿初始的帝企鹅数量。
第三行一个正整数M,表示命令的数量。接下来M行即命令,为题目描述所示。
1<=N<=30000,1<=M<=100000

Output

对于每个bridge命令与excursion命令,输出一行,为题目描述所示。

Sample Input

5
4 2 4 5 6
10
excursion 1 1
excursion 1 2
bridge 1 2
excursion 1 2
bridge 3 4
bridge 3 5
excursion 4 5
bridge 1 3
excursion 2 4
excursion 2 5

Sample Output

4
impossible
yes
6
yes
yes
15
yes
15
16

HINT

一眼LCT
#include<iostream>
#include<cstdio>
using namespace std;
const int N = 300000 + 5;
int v[N],sum[N],fa[N],c[N][2],sta[N],top,n,m;
bool rev[N]; char ch[10];
bool isroot( int x ){ return c[fa[x]][0]!=x&&c[fa[x]][1]!=x; }
void update( int x ){
	sum[x] = sum[c[x][0]] + sum[c[x][1]] + v[x];
}
void pushdown( int x ){
	if( rev[x] ){
		swap(c[x][1],c[x][0]);
		rev[c[x][1]] ^= 1; rev[c[x][0]] ^= 1; rev[x] = 0;
	}
}
void rotate( int x ){
	int y = fa[x], z = fa[y], l, r;
	l = (c[y][1]==x); r = l^1;
	if( !isroot(y) ) c[z][y==c[z][1]] = x;
	fa[x] = z; fa[y] = x; fa[c[x][r]] = y;
	c[y][l] = c[x][r]; c[x][r] = y;
	update(y); update(x);
}
void splay( int x ){
	sta[++top] = x;
	for( int t = x; !isroot(t); t = fa[t] ) sta[++top] = fa[t];
	while( top ) pushdown(sta[top--]);
	while( !isroot(x) ){
		int y = fa[x], z = fa[y];
		if( !isroot(y) ){
			if( (x==c[y][0])^(y==c[z][0]) ) rotate(x);
			else rotate(y);
		}
		rotate(x);
	}
}
void access( int x ){
	for( int t = 0; x; t = x, x = fa[x] ){
		splay(x); c[x][1] = t; update(x);
	}
}
void move_to_root( int x ){
	access(x); splay(x); rev[x] ^= 1;
}
void link( int x, int y ){
	move_to_root(x); fa[x] = y;
}
void cut( int x, int y ){
	move_to_root(x); access(y); splay(y); fa[x] = c[y][0] = 0;
}
int find( int x ){
	access(x); splay(x);
	while( c[x][0] ) x = c[x][0];
	return x;
}
void change( int x, int y ){
	move_to_root(x); access(y); splay(y);
}
int main(){
	scanf("%d", &n);
	for( int i = 1; i <= n; i++ ) scanf("%d", &v[i]);
	scanf("%d", &m);
	for( int i = 1, x, y; i <= m; i++ ){
		scanf("%s", ch); scanf("%d%d", &x, &y);
		if( ch[0] == 'b' ){
			if( find(x) != find(y) ){
				puts("yes"); link(x,y);
			} else{
				puts("no"); continue;
			}
		} 
		if( ch[0] == 'p' ){
			v[x] = y;
			access(x); splay(x);
		} 
		if( ch[0] == 'e' ){
			if( find(x) == find(y) ){
				change(x,y);
				printf("%d\n", sum[y]);
			} else{
				puts("impossible");
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值