[bzoj1751][Usaco2005 qua]Lake Counting

1751: [Usaco2005 qua]Lake Counting

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 261   Solved: 212
[ Submit][ Status][ Discuss]

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input


10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output


3

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,
and one along the right side.

HINT

noip普及组T1难度
#include<bits/stdc++.h>
using namespace std;
bool vis[105][105],mp[105][105]; char ch[105][105];
int dx[8] = {0,0,1,1,1,-1,-1,-1},
	dy[8] = {1,-1,0,-1,1,0,-1,1};
int n,m,ans;
void dfs( int x, int y ){
	vis[x][y] = 1;
	for( int i = 0; i < 8; i++ ){
		int xx = x + dx[i], yy = y + dy[i];
		if( !vis[xx][yy] && mp[xx][yy] ) dfs( xx, yy ); 
	}
}
int main(){
	scanf("%d%d", &n, &m);
	for( int i = 1; i <= n; i++ ) scanf("%s", ch[i]+1);
	for( int i = 1; i <= n; i++ )
		for( int j = 1; j <= m; j++ )
			mp[i][j] = ( ch[i][j] == 'W' );
	for( int i = 1; i <= n; i++ )
		for( int j = 1; j <= m; j++ )
			if( !vis[i][j] && mp[i][j] ){
				ans++; dfs( i, j );
			}
	printf("%d\n", ans);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值