1010. Radix (25)
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:6 110 1 10Sample Output 1:
2Sample Input 2:
1 ab 1 2Sample Output 2:
Impossible
#include <stdio.h>
#include <string.h>
int main() {
char str1[11], str2[11], tempStr[11];
long long sum1, tempSum;
int tag, radix, length1, length2, i, j, temp, tempLength, minRadix, flag;
scanf("%s%s", str1, str2);
scanf("%d%d", &tag, &radix);
length1 = strlen(str1);
length2 = strlen(str2);
sum1 = 0;
if(tag == 1) {
for(i = 0; i < length1; i ++) {
if(str1[i] < 97) {
temp = str1[i] - '0';
} else {
temp = str1[i] - 'a' + 10;
}
sum1 = radix * sum1 + temp;
}
} else {
for(i = 0; i < length2; i ++) {
if(str2[i] < 97) {
temp = str2[i] - '0';
} else {
temp = str2[i] - 'a' + 10;
}
sum1 = radix * sum1 + temp;
}
}
if(tag == 1) {
strcpy(tempStr, str2);
tempLength = length2;
} else {
strcpy(tempStr, str1);
tempLength = length1;
}
//printf("tempStr: %s\n", tempStr);
for(i = 0, minRadix = '1'; i < tempLength; i ++) {
if(minRadix < tempStr[i]) {
minRadix = tempStr[i];
}
}
if(minRadix <= '9') {
minRadix = minRadix - 48 + 1;
} else {
minRadix = minRadix - 97 + 10 + 1;
}
//printf("radix: %d\n", minRadix);
for(flag = 0; minRadix <= 36; minRadix ++) {
for(i = 0, tempSum = 0; i < tempLength; i ++) {
if(tempStr[i] <= '9') {
tempSum = tempSum * minRadix + tempStr[i] - '0';
} else {
tempSum = tempSum * minRadix + tempStr[i] - 'a' + 10;
}
}
if(sum1 == tempSum) {
flag = 1;
break;
}
}
if(flag == 0) {
printf("Impossible\n");
} else {
printf("%d\n", minRadix);
}
return 0;
}