求阶乘和

求阶乘和(the sum of Factorial)


描述
给你一个正整数N,请你求N!和,并输出最后结果
如给你5 , 即计算 1!+2!+3!+4!+5!
Input a positive integer N,and calculate the sum of n!.For example,n is 5 and calculate the following formula:
1!+2!+3!+4!+5!
 

输入
一个正整数N
a positive integer
 

输出
求得的阶乘和
The sum of n!
 

输入样例
5
 
输出样例
153
 

 
来源







#include<stdio.h>

int jiecheng(int n)
{
    int s=1;
    while(n>0)
    {
        s*=n;
        n--;
    }
    return s;
}


//主函数
int main()
{

    int n,sum=0;
    scanf("%d",&n);
    while(n>0)
    {
        sum+=jiecheng(n);
        n--;
    }
    printf("%d",sum);


    //输出回车
    printf("\n");
}



  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值