异常解决:util.NativeCodeLoader: Unable to load native-hadoop library for your platform

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/young_kim1/article/details/50324345

刚装好hadoop的时候,每次输入命令运行都会出现:

WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform… using builtin-java classes where applicable

提示hadoop不能加载本地库。

以前官网会提供32位的安装包,但目前提供的下载包为64位的,在linux 32位系统下安装后会一直提示错误“WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform… using builtin-java classes where applicable ”,但官网又不提供32位系统下的安装包,所以我们只能自己编译打包源码。

大家可以到$HADOOP_HOME/lib/native下,查看文件libhadoop.so.1.0.0,里面会显示Hadoop的位数,官网下载好的显示是64位的,截图如下:

这里写图片描述

如果你是64位操作系统,可以直接跳到第二步。

本地编译源码

具体操作看前一篇,这里

最后编译完以后,目标在

hadoop-2.7.1-src/hadoop-dist/target/hadoop-2.7.1下,将此目录下的lib/native替换掉$HADOOP_HOME/lib/native

配置环境变量

在/etc/profile中,添加下面配置:

export  HADOOP_COMMON_LIB_NATIVE_DIR=$HADOOP_HOME/lib/native
export  HADOOP_HOME=/home/hadoop/labc/hadoop-2.7.1
export  HADOOP_OPTS="-Djava.library.path=$HADOOP_HOME/lib:$HADOOP_COMMON_LIB_NATIVE_DIR"

最后记得使配置生效:source /etc/profile

并把相同配置添加到hadoop-env.sh文件末尾。

输入如下命令,没有报warn,说明修改成功。

这里写图片描述

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页