poj 1328 我的贪心第一题 爽!!!!!!

     
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
lymyfz      Log Out
Mail:0(0)
Login Log      Archive
POJ Challenge Call for Problems
Language:Default
Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24639 Accepted: 5296

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2 1 2 -3 1 2 1 1 2 0 2 0 0

Sample Output

Case 1: 2 Case 2: 1

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

All Rights Reserved 2003-2007 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator

 

#include<iostream>

using namespace std;

#include<math.h>

#include<algorithm>

int n,d;

struct sign//学会定义了结构体 

{

double left;

double right;

}sign1[1005];

double distance1(int left,int right)

{

if(d*d-right*right<0)

return -1;

double dis=sqrt((double)d*d-(double)right*right);

return dis;

}

bool comp(sign x,sign y)//学会定义comp 

{

return x.left<y.left;

}

int main()

{

int i,j;

int time=0;

//int signr,signl;

struct  coordinate

{

int left;

int right;

}coo[1005];

 

 

while(cin>>n>>d,n||d)

{

int q=0;

if(d<=0)

q=1;

 

int signcoo[1005];

//     memset(signcoo,0,sizeof(signcoo));

for(i=0;i<n;i++)

{

cin>>coo[i].left;

cin>>coo[i].right;

}

double temp;

int radar=0;

int cou=1;

for(i=0;i<n;i++)

{

 

temp=distance1(coo[i].left,coo[i].right);

if(temp<0)

q=1;

//cout<<temp;

//system("pause");

sign1[i].left=(coo[i].left-temp);

sign1[i].right=(coo[i].left+temp);

}

sort(sign1,sign1+n,comp);

double right=sign1[0].right;

for(i=1;i<n;i++)

{                                   //贪心算法 

if(sign1[i].left>right)

{

cou++;

right=sign1[i].right;

}

else if(sign1[i].right<right)

right=sign1[i].right;

}

if(q==1)

cou=-1;

getchar();//这个回车让自己输入,别打出回车 

getchar();

//cout<<endl;

     cout<<"Case "<<++time<<": "<<cou<<endl;

}

return 0;

}

 

 

 


 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
根据您的问,我理解您想了解POJ1328的Java解决方案。POJ1328是一个经典的问,也被称为"雷达安装"问,它涉及到在一个二维平面上安装雷达以覆盖所有岛屿的最小雷达数量。以下是一个Java解决方案的示例代码: ```java import java.util.Arrays; import java.util.Comparator; import java.util.Scanner; public class Main { public static void main(String[] args) { Scanner scanner = new Scanner(System.in); int caseNum = 1; while (true) { int n = scanner.nextInt(); if (n == 0) { break; } Island[] islands = new Island[n]; for (int i = 0; i < n; i++) { int x = scanner.nextInt(); int y = scanner.nextInt(); islands[i] = new Island(x, y); } int radarNum = getRadarNum(islands); System.out.println("Case " + caseNum + ": " + radarNum); caseNum++; } } private static int getRadarNum(Island[] islands) { Arrays.sort(islands, Comparator.comparingInt(Island::getRight)); int radarNum = 1; int rightMost = islands[0].getRight(); for (int i = 1; i < islands.length; i++) { if (islands[i].getLeft() > rightMost) { radarNum++; rightMost = islands[i].getRight(); } else { rightMost = Math.min(rightMost, islands[i].getRight()); } } return radarNum; } static class Island { private int left; private int right; public Island(int left, int right) { this.left = left; this.right = right; } public int getLeft() { return left; } public int getRight() { return right; } } } ``` 这段代码通过输入岛屿的坐标,计算出需要安装的最小雷达数量,并输出结果。它使用了排序和贪心算法的思想来解决问

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

代码随想录

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值