hdu 1024 Max Sum Plus Plus

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

Author
JGShining(极光炫影)
 

Recommend
 

Statistic | Submit | Discuss | Note

题解:

状态dp[i][j]
有前j个数,在选用第j个数的前提下,组成i组的和的最大值。
决策: 第j个数,是在第包含在第i组里面,还是自己独立成组。
方程 dp[i][j]=Max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j

Code:

import java.math.BigInteger;
import java.util.Arrays;
import java.util.Scanner;

public class Main {
	public static int maxn = 1000000 + 20;

	public static void main(String args[]) {
		Scanner Cin = new Scanner(System.in);
		int[] num = new int[maxn];
		int[] dp = new int[maxn];
		int[] maxs = new int[maxn];
		int maxx = -0x7fffffff,n,m;
		while (Cin.hasNext()) {
			m = Cin.nextInt();
			n = Cin.nextInt();
			Arrays.fill(dp, 0);
			Arrays.fill(maxs, 0);
			for (int i = 1; i <= n; i++) {
				num[i] = Cin.nextInt();
			}
			for (int i = 1; i <= m; i++) {//i表示分成i组
				maxx = -0x7fffffff;
				for (int j = i; j <= n; j++) {//j表示前j个数,合起来就是前j个数(取j的前提下)分成i组最大值是dp[j];
					dp[j] = Math.max(dp[j - 1] + num[j], maxs[j - 1] + num[j]);//maxs[j - 1]的值是dp[x](1 <= x <= j - 1)的最大值,也就是前x个元素(x从1到j - 1)分成i - 1组的最大值;
					maxs[j - 1] = maxx;//当前j - 1分成i组的最大值现在才更新,所以上一行是分成i - 1组 的最大值
					maxx = Math.max(maxx, dp[j]);//作为缓存,存的是1~j中分成i组的最大值
				}
			}
			System.out.println(maxx);
		}
	}
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值