POJ 2104 K-th Number

16 篇文章 0 订阅
16 篇文章 0 订阅

Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 51505
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
给出一排数,求区间第k小值

Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

分析

秘制手打可持久化线段树,表示看着线段树用的那么多于是手痒学一波,其实就是对于每一个节点单独开一颗线段树,但是这样明显会炸,于是我们就可以利用已经弄好的节点,很显然的,对于当前节点t[x],他的个数等于他前一个节点的个数加一,左儿子的位置和右儿子的位置与前一个节点是一样的,然后动态开点就好。
记得离散,我没离散秘制超时

代码

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>

#define N 100005
#define INF 0x7fffffff

struct NOTE
{
    int l,r,s;
}t[N*20];

int root[N],num[N],xnum[N],rank[N];

int n,m,mxn,tot;

void insert(int &x,int y,int p,int l,int r)
{
    x=++tot;
    t[x].l=t[y].l;
    t[x].r=t[y].r;
    t[x].s=t[y].s+1;
    if(l==r)
        return ;
    int mid=(l+r)/2;
    if(p<=mid)
        insert(t[x].l,t[y].l,p,l,mid);
        else insert(t[x].r,t[y].r,p,mid+1,r);
}

int query(int x,int y,int p,int l,int r)
{
    if(l==r)
        return l;
    int now=t[t[y].l].s-t[t[x].l].s,mid=(l+r)/2;
    if (now>=p)
        query(t[x].l,t[y].l,p,l,mid);
        else query(t[x].r,t[y].r,p-now,mid+1,r);
}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&num[i]);
        xnum[i]=num[i];
    }
    std::sort(xnum+1,xnum+n+1);
    for(int i=1;i<=n;i++)
    {
        rank[i]=std::lower_bound(xnum+1,xnum+n+1,num[i])-xnum;
    }
    for(int i=1;i<=n;i++)
    {
        insert(root[i],root[i-1],rank[i],1,n);
    }   

    while(m--)
    {
        int x,y,z;
        scanf("%d%d%d",&x,&y,&z);
        printf("%d\n",xnum[query(root[x-1],root[y],z,1,n)]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值