Description
有一家专卖一种商品的店,考虑连续的n天。
第i天上午会进货Ai件商品,中午的时候会有顾客需要购买Bi件商品,可以选择满足顾客的要求,或是无视掉他。
如果要满足顾客的需求,就必须要有足够的库存。问最多能够满足多少个顾客的需求。
Input
第一行一个正整数n (n<=250,000)。
第二行n个整数A1,A2,…An (0<=Ai<=10^9)。
第三行n个整数B1,B2,…Bn (0<=Bi<=10^9)。
Output
第一行一个正整数k,表示最多能满足k个顾客的需求。
第二行k个依次递增的正整数X1,X2,…,Xk,表示在第X1,X2,…,Xk天分别满足顾客的需求。
Sample Input
6
2 2 1 2 1 0
1 2 2 3 4 4
Sample Output
3
1 2 4
分析
第一眼看过去我只想到说用线段树来维护前i天的总共可用空间,然后把客户需求从小到大排,然后直接贪心,但嫌太麻烦,而且网上别人说这样过不了,于是看了题解。
正解是,假如剩下的容量可以满足当前客人就满足,并把它扔进大根堆,假如不能满足,就看他和堆顶谁的需求小,要需求小那个。
代码
#include <bits/stdc++.h>
#define N 250005
struct NOTE
{
int id,w;
bool operator < (const NOTE &a) const
{
return a.w>w;
} // end operator
};
std::priority_queue <NOTE> Q;
int n;
int a[N],b[N];
bool use[N];
int main()
{
scanf ("%d",&n);
for (int i = 1; i <= n; i++)
scanf ("%d",&a[i]);
for (int i = 1; i <= n; i++)
scanf ("%d",&b[i]);
long long ret = 0;
int ans = 0;
for (int i = 1; i <= n; i++)
{
ret+=a[i];
if (ret >= b[i])
{
ans++;
NOTE temp;
temp.id = i;
temp.w = b[i];
ret -= b[i];
Q.push(temp);
continue ;
} // end if
if (!Q.empty() && b[i]<Q.top().w)
{
ret += Q.top().w;
Q.pop();
NOTE temp;
ret -= b[i];
temp.id = i;
temp.w = b[i];
Q.push(temp);
} // end if
} // end for
while (!Q.empty())
{
use[Q.top().id] = true;
Q.pop();
}
printf("%d\n",ans);
for (int i = 1; i <= n; i++)
if (use[i])
printf("%d ",i);
printf("\n");
} // end main