BZOJ 3940: [Usaco2015 Feb]Censoring

Description

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty
of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest
issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his
cows not see (clearly, the magazine is in need of better editorial oversight).
FJ has taken all of the text from the magazine to create the string S of length at most 10^5 characters.
He has a list of censored words t_1 … t_N that he wishes to delete from S. To do so Farmer John finds
the earliest occurrence of a censored word in S (having the earliest start index) and removes that instance
of the word from S. He then repeats the process again, deleting the earliest occurrence of a censored word
from S, repeating until there are no more occurrences of censored words in S. Note that the deletion of one
censored word might create a new occurrence of a censored word that didn’t exist before.
Farmer John notes that the censored words have the property that no censored word appears as a substring of
another censored word. In particular this means the censored word with earliest index in S is uniquely
defined.Please help FJ determine the final contents of S after censoring is complete.
FJ把杂志上所有的文章摘抄了下来并把它变成了一个长度不超过10^5的字符串S。他有一个包含n个单词的列表,列表里的n个单词
记为t_1…t_N。他希望从S中删除这些单词。
FJ每次在S中找到最早出现的列表中的单词(最早出现指该单词的开始位置最小),然后从S中删除这个单词。他重复这个操作直到S中
没有列表里的单词为止。注意删除一个单词后可能会导致S中出现另一个列表中的单词
FJ注意到列表中的单词不会出现一个单词是另一个单词子串的情况,这意味着每个列表中的单词在S中出现的开始位置是互不相同的
请帮助FJ完成这些操作并输出最后的S

Input

The first line will contain S. The second line will contain N, the number of censored words. The next N lines contain the strings t_1 … t_N. Each string will contain lower-case alphabet characters (in the range a..z), and the combined lengths of all these strings will be at most 10^5.
第一行包含一个字符串S
第二行包含一个整数N
接下来的N行,每行包含一个字符串,第i行的字符串是t_i

Output

The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.
一行,输出操作后的S

Sample Input

begintheescapexecutionatthebreakofdawn

2

escape

execution

Sample Output

beginthatthebreakofdawn

分析

妈妈妈妈我会ac自动机啦。
ac自动机的核心在于有一个fail树,这个树其实跟kmp的next是很类似的,具体的有空再整理吧。
直接把单词表建AC自动机然后在上面跑就好了。
但是注意如果匹配的时候像kmp那样不停地沿着fail指针跳的话就会超时,所以要先预处理好每个点往某个字符串跳后会走到哪里,然后就可以过了。

代码

#include <bits/stdc++.h>

const int N = 100005;

int ch[N][26];
int len[N],val[N];

int sz;

char str[N];

void ins()
{
    int l = strlen(str), now = 0;
    for (int i = 0; i < l; i++)
        if (ch[now][str[i] - 'a'])
            now = ch[now][str[i] - 'a'];
        else now = ch[now][str[i] - 'a'] = ++sz;
    len[now] = l, val[now] = 1;
}

std::queue<int> Q;
int fail[N];

void getFail()
{
    for (int i = 0; i < 26; i++)
        if (ch[0][i])
            Q.push(ch[0][i]);
    while (!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        for (int i = 0; i < 26; i++)
        {
            int v = ch[u][i], k = ch[fail[u]][i];
            if (v)
                fail[v] = k, Q.push(v);
            else ch[u][i] = k;
        }
    }
}

char s[N];
int n,m;

int nx[N],ls[N],pos[N];

int main()
{
    scanf("%s", s + 1);
    n = strlen(s + 1);
    scanf("%d",&m);
    for (int i = 1; i <= m; i++)
    {
        scanf("%s", str);
        ins();
    }
    getFail();
    for (int i = 0; i <= n; i++) 
        nx[i] = i + 1;
    for (int i = 1; i <= n + 1; i++) 
        ls[i] = i - 1;
    int p = 0;
    for (int i = 1; i <= n; i++)
    {
        pos[i] = p = ch[p][s[i] - 'a'];
        if (val[p])
        {
            int now = i;
            for (int j = 1; j <= len[p]; j++) 
                ls[nx[now]] = ls[now], nx[ls[now]] = nx[now], now = ls[now];
            p = pos[now];
        }
    }
    for (int i = nx[0]; i != n + 1; i = nx[i]) 
        putchar(s[i]);
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值