hdu 1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 134859    Accepted Submission(s): 25637


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 
#include<iostream>
#include<string>
#define MAX 1000
using namespace
std ;
int
main()
{

    int
i ,j ,T ,cont = 0 ;
    int
A [MAX ] = { 0 },B [MAX ] = { 0 };
    char
a [MAX ],b [MAX ];
    cin >> T ;
    while
(
T --)
    {

        cin >> a >> b ;
        for
(
i = 0 ; i < MAX ; i ++)
        {

            A [i ] = 0 ;
            B [i ] = 0 ;
        }

        int
alen = strlen (a );
        int
blen = strlen (b );
        for
(
i = 0 ; i < alen ; i ++)
        {

            A [i ] = a [alen - 1 - i ] - 48 ;
        }

        for
(
i = 0 ; i < blen ; i ++)
        {

            B [i ] = b [blen - 1 - i ] - 48 ;
        }

        int
c = 0 ; //
        for (i = 0 ; i < MAX ; i ++)
        {

            int
s = A [i ] + B [i ] + c ;
            A [i ] =  s % 10 ;
            c = s / 10 ;
        }

        cout << "Case " <<++cont << ":" <<endl ;
        for
(
i = 0 ; i < alen ; i ++)
        {

            cout << a [i ];
        }

        cout << " + " ;
        for
(
i = 0 ; i < blen ; i ++)
        {

            cout << b [i ];
        }

        cout << " = " ;
        for
(
i = MAX - 1 ; i >= 0 ; i --)
        {

            if
(
A [i ])
                break
;
        }

        for
(
j = i ; j >= 0 ;j --)
        {

            cout << A [j ];
        }

        cout << endl ;
        if
(
T )
            cout << endl ;
    }

    return
0 ;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值