hdu 1164

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4219    Accepted Submission(s): 2531


Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

 

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
  
  
11 9412
 

Sample Output
  
  
11 2*2*13*181
 

Author
eddy
 

Recommend
JGShining
 
#include <iostream>
#include <math.h>
using namespace std;
int prime(int a)
{
	for(int i=2; i < sqrt(double(a)); i++)
	{
		if(a%i == 0)
			return 0;
	}
	return 1;
}
int main()
{
	int n, i;
	while (cin>>n)
	{
		if(prime(n))
			cout<<n<<endl;
		else
		{
			while(n != 1)
			{
				for(i = 2; i <= n; i++)
				{
					if(n%i == 0)
					{
						if(prime(i))
						{
							n /= i;
							cout<<i;
							if(n != 1)
								cout<<"*";
							break;
						}
					}
				}
			}
			cout<<endl;
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值