hdu 1335

Basically Speaking

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1230    Accepted Submission(s): 538


Problem Description
The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.

Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

It will support bases 2 through 16.
 

Input
The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.
 

Output
The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right justified in the display.
 

Sample Input
  
  
1111000 2 10 1111000 2 16 2102101 3 10 2102101 3 15 12312 4 2 1A 15 2 1234567 10 16 ABCD 16 15
 

Sample Output
  
  
120 78 1765 7CA ERROR 11001 12D687 D071
 

Source
 

Recommend
Ignatius.L
 
#include <iostream>
#include <string>
#include<iomanip>
using namespace std;
string change(string str, int from, int to)
{
	int r, i, n;
	string rstr;
	int l = str.length();
	n = 1;
	r = 0;
	for (i = 0; i < l; i++)
	{
		if (str[l-i-1] == '1')
			r += n;
		else if (str[l-i-1] == '2')
			r += n*2;
		else if (str[l-i-1] == '3')
			r += n*3;
		else if (str[l-i-1] == '4')
			r += n*4;
		else if (str[l-i-1] == '5')
			r += n*5;
		else if (str[l-i-1] == '6')
			r += n*6;
		else if (str[l-i-1] == '7')
			r += n*7;
		else if (str[l-i-1] == '8')
			r += n*8;
		else if (str[l-i-1] == '9')
			r += n*9;
		else if (str[l-i-1] == 'A')
			r += n*10;
		else if (str[l-i-1] == 'B')
			r += n*11;
		else if (str[l-i-1] == 'C')
			r += n*12;
		else if (str[l-i-1] == 'D')
			r += n*13;
		else if (str[l-i-1] == 'E')
			r += n*14;
		else if (str[l-i-1] == 'F')
			r += n*15;
		n *= from;
	}
	while (r)
	{
		i = r%to;
		if (i == 1)
			rstr = '1' + rstr;
		else if (i == 2)
			rstr = '2' + rstr;
		else if (i == 3)
			rstr = '3' + rstr;
		else if (i == 4)
			rstr = '4' + rstr;
		else if (i == 5)
			rstr = '5' + rstr;
		else if (i == 6)
			rstr = '6' + rstr;
		else if (i == 7)
			rstr = '7' + rstr;
		else if (i == 8)
			rstr = '8' + rstr;
		else if (i == 9)
			rstr = '9' + rstr;
		else if (i == 10)
			rstr = 'A' + rstr;
		else if (i == 11)
			rstr = 'B' + rstr;
		else if (i == 12)
			rstr = 'C' + rstr;
		else if (i == 13)
			rstr = 'D' + rstr;
		else if (i == 14)
			rstr = 'E' + rstr;
		else if (i == 15)
			rstr = 'F' + rstr;
		else if (i == 0)
			rstr = '0' + rstr;
		r /= to;
	}
	return rstr;
}
int main()
{
	int from, to;
	string str;
	while (cin >> str >> from >>to)
	{
		str = change(str, from, to);
		if (str.length() > 7)
			cout<<"  ERROR"<<endl;
		else
			cout<<setiosflags(ios::right)<<setw(7)<<str<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值