hdu 1798

Tell me the area

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1382    Accepted Submission(s): 430


Problem Description
    There are two circles in the plane (shown in the below picture), there is a common area between the two circles. The problem is easy that you just tell me the common area.

 

Input
There are many cases. In each case, there are two lines. Each line has three numbers: the coordinates (X and Y) of the centre of a circle, and the radius of the circle.
 

Output
For each case, you just print the common area which is rounded to three digits after the decimal point. For more details, just look at the sample.
 

Sample Input
  
  
0 0 2 2 2 1
 

Sample Output
  
  
0.108
 

Author
wangye
 

Source
 

Recommend
wangye


//分三种情况考虑两个圆关系:1.两圆相离、外切或至少有一圆半径为0; 
//                          2.两圆内切、内含;
//                          3.相交。
//这里PI用acos(-1.0),用3.1415926的话会WA.
#include <stdio.h>
#include <math.h>
#define PI acos(-1.0)
int main()
{
	double x1, y1, r1, x2, y2, r2, dis, s, angle1, angle2, s1, s2, s3, s4;
	while (~scanf("%lf%lf%lf%lf%lf%lf", &x1, &y1, &r1, &x2, &y2, &r2))
	{
		dis = sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2));
		if(dis >= r1 + r2 || r1 == 0 || r2 == 0)
			s = 0;
		else if(dis <= fabs(r1 - r2))
		{
			r1 = r1 > r2 ? r2 : r1;
			s = PI * r1 * r1;
		}
		else
		{
			angle1 = acos((r1 * r1 + dis * dis - r2 * r2) / (2 * r1 * dis));
			angle2 = acos((r2 * r2 + dis * dis - r1 * r1) / (2 * r2 * dis));
			s1 = angle1 * r1 * r1;
			s2 = r1 * r1 * sin(angle1) * cos(angle1);
			s3 = angle2 * r2 * r2;
			s4 = r2 * r2 * sin(angle2) * cos(angle2);
			s = s1 - s2 + s3 - s4;
		}
		printf("%.3lf\n", s);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值