1022. Digital Library (30)

题目如下:

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
分析:

这一题没啥可说的,就是字符串处理,需要注意的字符串可以带空格,所以在输入的时候需要特别处理,比如在scanf之后如果再用gets需要把换行符过滤掉。另外gets得到的字符串把行末的换行符也算进去了,因此还需要将其处理掉。

另外需要注意的就是query可能会大于80个字符!我一开始没注意把query也当成80个字符了,结果有一个case一直过不了,很显然如果超过80最后比较的时候,query信息不全,导致比较出错。属性的最大长度是80因此query的最大长度是83!

这一题要是用C++ string类估计就没这问题了。。。


代码如下:

#include <stdio.h>
#include <string.h>

typedef struct _hash
{
	char id[10];
	char key[82];
}hash;

int cmp(const void *a,const void *b)
{
	return strcmp((char *)a,(char *)b);
}

int main(int argc,char* argv[])
{
	int i,j,n,m,item,count;
	hash h[5][10000];
	char id[10],title[82],author[82];
	char keyword[82],publisher[82],year[8];
	char query[100];
	char res[10000][82];

	//freopen("input","r",stdin);

	scanf("%d",&n);
	getchar();
	
	for(i=0;i<n;i++)
	{
		fgets(id,10,stdin);
		fgets(title,82,stdin);
		fgets(author,82,stdin);
		fgets(keyword,82,stdin);
		fgets(publisher,82,stdin);
		fgets(year,8,stdin);

		id[strlen(id)-1] = 0;
		title[strlen(title)-1] = 0;
		author[strlen(author)-1] = 0;
		keyword[strlen(keyword)-1] = 0;
		publisher[strlen(publisher)-1] = 0;
		year[strlen(year)-1] = 0;

		for(j=0;j<5;j++)
			strcpy(h[j][i].id,id);
		strcpy(h[0][i].key,title);
		strcpy(h[1][i].key,author);
		strcpy(h[2][i].key,keyword);
		strcpy(h[3][i].key,publisher);
		strcpy(h[4][i].key,year);
	}

	scanf("%d",&m);
	getchar();
	
	for(i=0;i<m;i++)
	{
		fgets(query,100,stdin);
		item = query[0]-'0'-1;
		query[strlen(query)-1] = 0;
		printf("%s\n",query);

		count = 0;
		for(j=0;j<n;j++)
		{
			if(item != 2)
			{
				if(!strcmp(query+3,h[item][j].key))
					strcpy(res[count++],h[item][j].id);
			}
			else
			{
			  if(strstr(h[item][j].key,query+3) != NULL)
					strcpy(res[count++],h[item][j].id);
			}
		}
		
		qsort(res,count,sizeof(res[0]),cmp);
		if( !count )
			printf("Not Found\n");
		for(j=0;j<count;j++)
			printf("%s\n",res[j]);
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值