POJ 3181 Dollar Dayz(动态规划+大数)

题目传送门

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 
 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

Source

USACO 2006 January Silver

题意:给你两个数n,k,让你用1到k这k个数表示n,问有几种方法

题解:大家看看这两个博客,可以说是很详细了===>>大牛博客1大牛博客2

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
long long n,m,inf=1e18,a[1110][110],b[1110][110];
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(a,0,sizeof(a));//不能忘
        memset(b,0,sizeof(b));
        for(int i=1;i<=m;i++)
            a[0][i]=1;
        for(int j=1;j<=m;j++)
            for(int i=1;i<=n;i++)
            {
                if(i<j)
                {
                    a[i][j]=a[i][j-1];
                    b[i][j]=b[i][j-1];
                    continue;//不能忘
                }
                b[i][j]=b[i][j-1]+b[i-j][j]+(a[i-j][j]+a[i][j-1])/inf;
                a[i][j]=(a[i-j][j]+a[i][j-1])%inf;//a[i][j]=a[i-j][j]+(a[i][j-1])%inf;括号不能错了
            }
        if(b[n][m])
            printf("%I64d",b[n][m]);//记录大数前17位
        printf("%I64d",a[n][m]);//记录大数后17位
        cout<<endl;
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值