HDOJ 题目1690Bus System(最短路径)



Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6610    Accepted Submission(s): 1706


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
  
  
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
  
  
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:   2722  1596  1385  1142  1548 
 

ac代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

typedef long long int64;
const int64 INF = 1e18;
const int VN  = 105;

int n;
int m;
int64 d[VN][VN];

int64 X[VN];
int64 L1,L2,L3,L4;
int64 C1,C2,C3,C4;

inline int64 abs(int64 x){return x<0?-x:x;}
void init(){
    for(int i=1; i<=n; ++i){
        d[i][i] = 0;
        for(int j=i+1; j<=n; ++j)
            d[i][j]=d[j][i]=INF;
    }
}

int64 getCost(int64 dist){
    if(0<dist && dist<=L1) return C1;
    if(L1<dist && dist<=L2) return C2;
    if(L2<dist && dist<=L3) return C3;
    if(L3<dist && dist<=L4) return C4;
    return INF;
}

void Floyd(){
    for(int k=1; k<=n; ++k)
    for(int i=1; i<=n; ++i)if(d[i][k]!=INF)
    for(int j=1; j<=n; ++j)if(d[k][j]!=INF)
        d[i][j]=min(d[i][j], d[i][k]+d[k][j]);
}

int main(){
    int T,cas=1;
    scanf("%d",&T);
    while(T--){
        cin >> L1 >> L2 >> L3 >> L4;
        cin >> C1 >> C2 >> C3 >> C4;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; ++i)
            cin >> X[i];
        init();
        for(int i=1; i<=n; ++i){
            for(int j=i+1; j<=n; ++j){
                d[i][j]=d[j][i]=getCost(abs(X[i]-X[j]));
            }
        }
        Floyd();
        int u,v;

        printf("Case %d:\n",cas++);
        for(int i=0; i<m; ++i){
            scanf("%d%d",&u,&v);
            if(d[u][v]!=INF){
                printf("The minimum cost between station %d and station %d is ",u,v);
                cout << d[u][v] << ".\n";
            }
            else 
                printf("Station %d and station %d are not attainable.\n",u,v);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值