HDOJ 题目4160Dolls(二分图,最小路径覆盖)



Dolls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1078    Accepted Submission(s): 524


Problem Description
Do you remember the box of Matryoshka dolls last week? Adam just got another box of dolls from Matryona. This time, the dolls have different shapes and sizes: some are skinny, some are fat, and some look as though they were attened. Specifically, doll i can be represented by three numbers wi, li, and hi, denoting its width, length, and height. Doll i can fit inside another doll j if and only if wi < wj , li < lj , and hi < hj .
That is, the dolls cannot be rotated when fitting one inside another. Of course, each doll may contain at most one doll right inside it. Your goal is to fit dolls inside each other so that you minimize the number of outermost dolls.
 

Input
The input consists of multiple test cases. Each test case begins with a line with a single integer N, 1 ≤ N ≤ 500, denoting the number of Matryoshka dolls. Then follow N lines, each with three space-separated integers wi, li, and hi (1 ≤ wi; li; hi ≤ 10,000) denoting the size of the ith doll. Input is followed by a single line with N = 0, which should not be processed.
 

Output
For each test case, print out a single line with an integer denoting the minimum number of outermost dolls that can be obtained by optimally nesting the given dolls.
 

Sample Input
  
  
3 5 4 8 27 10 10 100 32 523 3 1 2 1 2 1 1 1 1 2 4 1 1 1 2 3 2 3 2 2 4 4 4 0
 

Sample Output
  
  
1 3 2
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   4153  4159  4158  4156  4155 
 ac代码
#include<stdio.h>
#include<vector>
#include<string.h>
#include<iostream>
using namespace std;
int n;
struct node
{
    int h,w,l;
}b[100000];
int v[100000],link[100000];
vector<int>p[100000];
int jud(int i,int j)
{
    if(b[i].w<b[j].w&&b[i].l<b[j].l&&b[i].h<b[j].h)
        return 1;
    return 0;
}
int dfs(int fa)
{
    int i;
    for(i=0;i<p[fa].size();i++)
    {
        if(!v[p[fa][i]])
        {
            v[p[fa][i]]=1;
            if(link[p[fa][i]]==-1||dfs(link[p[fa][i]]))
            {
                link[p[fa][i]]=fa;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(scanf("%d",&n)!=EOF,n)
    {
        int i,j,c=0;
        for(i=0;i<=2*n;i++)
            p[i].clear();
        for(i=0;i<n;i++)
            scanf("%d%d%d",&b[i].w,&b[i].l,&b[i].h);
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
            {
                if(jud(i,j))
                    p[i].push_back(j);
            }
        memset(link,-1,sizeof(link));
        for(i=0;i<n;i++)
        {
            memset(v,0,sizeof(v));
            if(dfs(i))
                c++;
        }
        printf("%d\n",n-c);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值