Examining the Rooms
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1092 Accepted Submission(s): 660
Problem Description
A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.
Input
The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)
Output
Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.
Sample Input
3 3 1 3 2 4 2
Sample Output
0.3333 0.6667 0.6250HintSample Explanation When N = 3, there are 6 possible distributions of keys: Room 1 Room 2 Room 3 Destroy Times #1 Key 1 Key 2 Key 3 Impossible #2 Key 1 Key 3 Key 2 Impossible #3 Key 2 Key 1 Key 3 Two #4 Key 3 Key 2 Key 1 Two #5 Key 2 Key 3 Key 1 One #6 Key 3 Key 1 Key 2 One In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1. In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room
Source
Recommend
思路:
题意:给N个元素,让我们求K个环排列的方法数。
斯特林第一类数的第推公式:
S(N,0)=0; S(N,N)=1; S(0,0)=0; S(N,K)=S(N-1,K-1)+S(N-1,K)*(N-1);
这个公式的意思是:当前N-1个数构成K-1 个环的时候,加入第N个 ,N只能构成单环!—S(N-1,K-1)如果N-1个数构
成K个环的时候,加入第N个,N可以任意加入,N-1内的一个环里,所以(N-1)*S(N-1,K)这个题目里,因为不能破坏
第1个门:所以 S(N,K)-S(N-1,K-1)才是能算构成K个环的方法数!就是去掉1自己成环的情况 。
ac代码
#include<stdio.h>
#include<string.h>
__int64 fac[25],si[25][25];
void fun()
{
int i,j;
fac[0]=fac[1]=1;
for(i=2;i<25;i++)
fac[i]=fac[i-1]*i;
si[0][0]=0;
si[1][1]=1;
for(i=2;i<25;i++)
for(j=1;j<=i;j++)
{
si[i][j]=si[i-1][j-1]+(i-1)*si[i-1][j];
}
}
int main()
{
int t;
scanf("%d",&t);
fun();
while(t--)
{
int n,k,i;
__int64 num=0;
scanf("%d%d",&n,&k);
for(i=1;i<=k;i++)
{
num+=si[n][i]-si[n-1][i-1];
}
printf("%.4lf\n",1.0*num/fac[n]);
}
}