0 or 1
Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2668 Accepted Submission(s): 688
Problem Description
Solving problem is a interesting thing. Yifenfei like to slove different problem,because he think it is a way let him more intelligent. But as we know,yifenfei is weak in math. When he come up against a difficult math problem, he always try to get a hand. Now the problem is coming! Let we
define T(n) as the sum of all numbers which are positive integers can divied n. and S(n) = T(1) + T(2) + T(3)…..+T(n).
define T(n) as the sum of all numbers which are positive integers can divied n. and S(n) = T(1) + T(2) + T(3)…..+T(n).
Input
The first line of the input contains an integer T which means the number of test cases. Then T lines follow, each line consists of only one positive integers n. You may assume the integer will not exceed 2^31.
Output
For each test case, you should output one lines of one integer S(n) %2. So you may see the answer is always 0 or 1 .
Sample Input
3 1 2 3
Sample Output
1 0 0HintHint S(3) = T(1) + T(2) +T(3) = 1 + (1+2) + (1+3) = 8 S(3) % 2 = 0
Author
yifenfei
Source
Recommend
ac代码
#include<string.h>
#include<stdio.h>
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
__int64 n,i,sum=0;
scanf("%I64d",&n);
for(i=1;i*i<=n;i++)
{
sum++;
if(2*i*i<=n)
sum++;
}
if(sum%2==0)
printf("0\n");
else
printf("1\n");
}
}