HDOJ 题目2289 Cup(数学,二分)

90 篇文章 1 订阅

Cup

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4431    Accepted Submission(s): 1388


Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height? 

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

 

Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

Sample Input
  
  
1 100 100 100 3141562
 

Sample Output
  
  
99.999024
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2298  2141  1551  1399  2446 
 ac代码
#include<stdio.h>
#include<string.h>
#include<math.h>
#define pi acos(-1.0)
double area(double r1,double r2,double h1,double h)
{
	double u=(h1/h)*(r2-r1)+r1;
	return (r1*r1+u*u+r1*u)*h1*pi/3;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		double r1,r2,h,v,mid,l=0,r,tv;
		scanf("%lf%lf%lf%lf",&r1,&r2,&h,&v);
		r=h;
		mid=(l+r)/2;
		tv=area(r1,r2,mid,h);
		while(fabs(tv-v)>1e-7)
		{
			if(fabs(r-l)<=1e-7)//不加这个会超时啊
				break;
			if(tv>v)
			{
				r=mid;
			}
			else
				l=mid;
			mid=(l+r)/2;
			tv=area(r1,r2,mid,h);
		}
		printf("%.6lf\n",mid);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值