HDOJ 题目2830 Matrix Swapping II(动态规划)



Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1299    Accepted Submission(s): 865


Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.  

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

Output
Output one line for each test case, indicating the maximum possible goodness.
 

Sample Input
  
  
3 4 1011 1001 0001 3 4 1010 1001 0001
 

Sample Output
  
  
4 2 Note: Huge Input, scanf() is recommended.
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2577  1159  1978  1158  1227 
 ac代码
#include<stdio.h>
#include<string.h>
int num[1010],hash[1010];
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j,max=0;
		char c;
		for(i=0;i<n;i++)
		{
			getchar();
			memset(hash,0,sizeof(hash));
			for(j=0;j<m;j++)
			{
				scanf("%c",&c);
				if(c=='1')
					num[j]++;
				else
					num[j]=0;
				hash[num[j]]++;
			}
			for(j=1008;j>=0;j--)
			{
				hash[j]+=hash[j+1];
				if(hash[j]*j>max)
					max=hash[j]*j;
			}
		}
		printf("%d\n",max);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值