HDOJ 题目1795 The least one(水题)

The least one

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 376    Accepted Submission(s): 132


Problem Description
  In the RPG game “go back ice age”(I decide to develop the game after my undergraduate education), all heros have their own respected value, and the skill of killing monsters is defined as the following rule: one hero can kill the monstrers whose respected values are smaller then himself and the two respected values has none common factor but 1, so the skill is the same as the number of the monsters he can kill. Now each kind of value of the monsters come. And your hero have to kill at least M ones. To minimize the damage of the battle, you should dispatch a hero with minimal respected value. Which hero will you dispatch ? There are Q battles, in each battle, for i from 1 to Q, and your hero should kill Mi ones at least. You have all kind of heros with different respected values, and the values(heros’ and monsters’) are positive.
 

Input
  The first line has one integer Q, then Q lines follow. In the Q lines there is an integer Mi, 0<Q<=1000000, 0<Mi<=10000.
 

Output
  For each case, there are Q results, in each result, you should output the value of the hero you will dispatch to complete the task.
 

Sample Input
  
  
2 3 7
 

Sample Output
  
  
5 11
 

Author
wangye
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:   1793  1796  1797  1794  1788 
 
题目说的好抽象啊,,就是找第一个比n大的素数,,原本想用不用二分找啊,,,居然不用也过了,,水
ac代码
#include<stdio.h>
#include<string.h>
int a[1000100],k;
void fun()
{
	int i,j;
	k=0;
	for(i=2;i<1000100;i++)
	{
		int w=1;
		for(j=2;j*j<=i;j++)
			if(i%j==0)
			{
				w=0;
				break;
			}
		if(w)
			a[k++]=i;
	}
}
int main()
{
	int t,i;
	fun();
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		for(i=0;i<k;i++)
		{
			if(a[i]>n)
				break;
		}
		printf("%d\n",a[i]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值