NYOJ 题目1070 诡异的电梯【Ⅰ】(dp)

诡异的电梯【Ⅰ】

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

新的宿舍楼有 N(1≤N≤100000)  and M(1≤M≤100000)个学生在新的宿舍楼里为了节约学生的时间也为了鼓励学生锻炼身体所以规定该宿舍楼里的电梯在相邻的两层之间是不会连续停下(即,如果在第2层停下就不能在第3层停下。).所以,如果有学生在相邻的两层之间要停下则其中的一部分学生必须选择走楼梯来代替。规定:一个人走下一层楼梯的花费为A,走上一层楼梯的花费为B。(1≤A,B≤100)现在请你设计一个算法来计算出所有学生走楼梯花费的最小费用总和。 所有的学生一开始都在第一层,电梯不能往下走,在第二层的时候电梯可以停止。


输入
输入有几组数据T。T(1≤T≤10)
每组数据有N (1≤N≤100000),M(1≤M≤100000),A,B(1≤A,B≤100)。
接下来有M个数字表示每个学生想要停的楼层。

输出
输出看样例。
样例输入
1
3 2 1 1
2 3
样例输出
Case 1: 1
提示
原题:
The new dormitory has N(1≤N≤100000) floors and M(1≤M≤100000)students. In the new dormitory, in order to save student's time as well as encourage student exercise, the elevator in dormitory will not stop in adjacent floor. So if there are people want to get off the elevator in adjacent floor, one of them must walk one stair instead. Suppose a people go down 1 floor costs A energy, go up 1 floor costs B energy(1≤A,B≤100). Please arrange where the elevator stop to minimize the total cost of student's walking cost.All students and elevator are at floor 1 initially, and the elevator can not godown and can stop at floor 2.


OUTPUT:
Output case number first, then the answer, the minimum of the total cost of student's walking cost.
来源
翻译【2014湘潭邀请赛】
上传者
ACM_钟诗俊
思路:

用dp【i】表示从1层上到第 i 层花费的最小的体力。

因为不能在相邻的楼层停留,所以可以从dp【i-2】转移,但这样不是最优的还要从dp【i-3】转移,因为这样的话就可以到达所有的楼层。我们只要在所有的之间dp最优即可。

其他要注意的一个条件是,从dp【i-3】转移时,中间两层的人有四种选择:

1:都上去或都下来

2:上面的上去一层,下面的下来一层

3:上面的下来两层,下面的上去两层,(当时没有考虑到这个,要细心啊)

那么代码就很好写了、

ac代码

#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
#define min(a,b) (a>b?b:a)
int a[100100],dp[100100];
int main()
{
	int t,c=0;
	scanf("%d",&t);
	while(t--)
	{
		int n,m,up,down,i,cot;
		scanf("%d%d%d%d",&n,&m,&up,&down);
		memset(a,0,sizeof(a));
		cot=min(up,down);
		for(i=0;i<m;i++)
		{
			int x;
			scanf("%d",&x);
			a[x]++;
		}
		for(i=3;i<=n;i++)
			dp[i]=INF;
		dp[0]=dp[1]=dp[2]=0;
		for(i=3;i<=n;i++)
		{
			dp[i]=min(dp[i],dp[i-2]+a[i-1]*cot);
			if(i>=4)
			{
				int temp=INF;;
				temp=min(a[i-2]*down*2+a[i-1]*down,a[i-2]*up+a[i-1]*up*2);
				temp=min(temp,a[i-2]*up+a[i-1]*down);
				temp=min(temp,a[i-2]*2*down+a[i-1]*up*2);
				dp[i]=min(dp[i-3]+temp,dp[i]);
			}
		}
		printf("Case %d: %d\n",++c,dp[n]);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值