HDOJ 题目3478 Catch(染色法判二分图)

Catch

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1299    Accepted Submission(s): 635


Problem Description
A thief is running away!
We can consider the city where he locates as an undirected graph in which nodes stand for crosses and edges stand for streets. The crosses are labeled from 0 to N–1. 
The tricky thief starts his escaping from cross S. Each moment he moves to an adjacent cross. More exactly, assume he is at cross u at the moment t. He may appear at cross v at moment t + 1 if and only if there is a street between cross u and cross v. Notice that he may not stay at the same cross in two consecutive moment.
The cops want to know if there’s some moment at which it’s possible for the thief to appear at any cross in the city.
 

Input
The input contains multiple test cases:
In the first line of the input there’s an integer T which is the number of test cases. Then the description of T test cases will be given. 
For any test case, the first line contains three integers N (≤ 100 000), M (≤ 500 000), and S. N is the number of crosses. M is the number of streets and S is the index of the cross where the thief starts his escaping.
For the next M lines, there will be 2 integers u and v in each line (0 ≤ u, v < N). It means there’s an undirected street between cross u and cross v.

 

Output
For each test case, output one line to tell if there’s a moment that it’s possible for the thief to appear at any cross. Look at the sample output for output format.

 

Sample Input
  
  
2 3 3 0 0 1 0 2 1 2 2 1 0 0 1
 

Sample Output
  
  
Case 1: YES Case 2: NO
Hint
For the first case, just look at the table below. (YES means the thief may appear at the cross at that moment)
For the second input, at any moment, there’s at least one cross that the thief can’t reach.
 

Source
 

Recommend
zhengfeng   |   We have carefully selected several similar problems for you:   3486  3484  3483  3482  3481 
 
ac代码
不判联通也能过
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int s,n,m,cnt,ans;
int head[100010],vis[100010],color[100010];
struct s
{
	int u,v,next;
}edge[500010*2];
void add(int u,int v)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
void dfs(int u)
{
	vis[u]=1;
	ans++;
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		int v=edge[i].v;
		if(vis[v]==0)
			dfs(v);
	}
}
int link()
{
	ans=0;
	memset(vis,0,sizeof(vis));
	dfs(0);
	if(ans==n)
		return 1;
	return 0;
}
int dfs(int u,int c)
{
	if(!color[u])
	{
		color[u]=c;
	}
	else
	{
		if(color[u]==c)
			return 0;
		return 1;
	}
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		int v=edge[i].v;
		if(dfs(v,-c))
			return 1;
	}
	return 0;
}
int jud()
{
	memset(color,0,sizeof(color));
	int i;
	for(i=0;i<n;i++)
	{
		if(!color[i])
			if(dfs(i,1))
				return 0;
	}
	return 1;
}
int main()
{
	int t,c=0;
	scanf("%d",&t);
	while(t--)
	{
		int i;
		scanf("%d%d%d",&n,&m,&s);
		memset(head,-1,sizeof(head));
		cnt=0;
		for(i=0;i<m;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			add(u,v);
			add(v,u);
		}
		if(link()&&jud()==0)
		{
			printf("Case %d: YES\n",++c);
		}
		else
			printf("Case %d: NO\n",++c);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值