HDOJ 题目3367 Pseudoforest(并查集)

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1932    Accepted Submission(s): 746


Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
 

Output
Output the sum of the value of the edges of the maximum pesudoforest.
 

Sample Input
  
  
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
 

Sample Output
  
  
3 5
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3362  3368  3365  3369  3366 
 

题意:求出一个最大的子图(子图的每个连通分量最多有一个环)

   用kruskal算法求出最大生成树  不过要判断是否有环  2树合并时 :若2个子树都有环不能合并 只有一个有环可以合并 但合并后的树有环 若2个子树都没环直接合并

ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int pre[10010],vis[10010];
struct s
{
	int u,v,w;
}edge[100100];
int n,m;
int cmp(const void *a,const void *b)
{
	return (*(struct s *)b).w-(*(struct s *)a).w;
}
void init()
{
	int i;
	for(i=0;i<=n;i++)
		pre[i]=i;
}
int find(int x)
{
	if(x==pre[x])
		return x;
	return pre[x]=find(pre[x]);
}
int merge(int u,int v)
{
	int fu=find(u);
	int fv=find(v);
	if(fu==fv)
	{
		if(!vis[fu])
		{
			vis[fu]=1;
			return 1;
		}
		return 0;
	}
	if(vis[fu]&&vis[fv])
		return 0;
	if(vis[fu])
		pre[fv]=fu;
	else
		pre[fu]=fv;
	return 1;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF,n||m)
	{
		int i;
		init();
		for(i=0;i<m;i++)
		{
			int u,v,w;
			scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
		}
		qsort(edge,m,sizeof(edge[0]),cmp);
		int ans=0;
		memset(vis,0,sizeof(vis));
		for(i=0;i<m;i++)
		{
			int u=edge[i].u;
			int v=edge[i].v;
			int w=edge[i].w;
			if(merge(u,v))
				ans+=w;
		}
		printf("%d\n",ans);
	}
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值