UVA 题目1099 - Sharing Chocolate(状态压缩DP+记忆化搜索)

Chocolate in its many forms is enjoyed by millions of people around the world every day. It is a truly
universal candy available in virtually every country around the world.
You find that the only thing better than eating chocolate is to share it with friends. Unfortunately
your friends are very picky and have different appetites: some would like more and others less of the
chocolate that you offer them. You have found it increasingly difficult to determine whether their
demands can be met. It is time to writte a program that solves the problem once and for all!
Your chocolate comes as a rectangular bar. The bar consists of same-sized rectangular pieces. To
share the chocolate you may break one bar into two pieces along a division between rows or columns of
the bar. You or the may then repeatedly break the resulting pieces in the same manner. Each of your
friends insists on a getting a single rectangular portion of the chocolate that has a specified number of
pieces. You are a little bit insistent as well: you will break up your bar only if all of it can be distributed
to your friends, with none left over.
For exampla, Figure 9 shows one way that a chocolate bar consisting of 3 × 4 pieces can be split
into 4 parts that contain 6, 3, 2, and 1 pieces respectively, by breanking it 3 times (This corresponds
to the first sample input.)
Input
The input consists of multiple test cases each describing a chocolate bar to share. Each description
starts with a line containing a single integer n (1 ≤ n ≤ 15), the number of parts in which the bar is
supposed to be split. This is followed by a line containing two integers x and y (1 ≤ x, y ≤ 100), the
dimensions of the chocolate bar. The next line contains n positive integers, giving the number of pieces
that are supposed to be in each of the n parts.
The input is terminated by a line containing the integer zero.
Output
For each test case, first display its case number. Then display whether it is possible to break the
chocolate in the desired way: display ‘Yes’ if it is possible, and ‘No’ otherwise. Follow the format of
the sample output.
Sample Input
4
3 4
6 3 2 1
2
2 3
1 5
0
Sample Output
Case 1: Yes

Case 2: No

题目大意:

给一块x*y大小的巧克力,然后要分成n块,问能否分。

ac代码

#include <stdio.h>   
#include <string.h>   
#include <algorithm>   
#define min(a,b) ((a)<(b)?(a):(b))   
using namespace std;  
const int N = 17;  
const int MAXN = (1<<N);  
const int XN = 105;  
int n, x, y, big[N], sum[MAXN];  
bool dp[MAXN][XN], vis[MAXN][XN];  
  
int bitcount(int x) {  
    if (x == 0) return 0;  
    return bitcount(x>>1) + (x&1);  
}  
bool solve(int s, int x) {  
    if (vis[s][x]) return dp[s][x];  
    vis[s][x] = 1;  
    if (bitcount(s) == 1) return dp[s][x] = true;  
    if (sum[s] % x) return dp[s][x] = false;  
    int y = sum[s] / x;  
    for (int s0 = (s - 1)&s; s0 > 0; s0 = (s0 - 1)&s) {  
        int s1 = (s^s0);  
        if (sum[s0]%x==0 && solve(s0, min(x, sum[s0]/x)) && solve(s1, min(x, sum[s1]/x)))   
            return dp[s][x] = true;  
        if (sum[s0]%y==0 && solve(s0, min(y, sum[s0]/y)) && solve(s1, min(y, sum[s1]/y)))   
            return dp[s][x] = true;  
    }  
    return dp[s][x] = false;  
}  
  
int main() {  
    int cas = 0;  
    while (~scanf("%d", &n) && n) {  
        scanf("%d%d", &x, &y);  
        memset(vis, 0, sizeof(vis));  
        memset(sum, 0, sizeof(sum));  
        for (int i = 0; i < n; i++)  
            scanf("%d", &big[i]);  
        for (int state = 0; state < (1<<n); state++) {  
            for (int i = 0; i < n; i++)  
                if (state&(1<<i))  
                    sum[state] += big[i];  
        }  
        if (sum[(1<<n)-1] != x * y) {printf("Case %d: No\n", ++cas); continue;}  
        printf("Case %d: %s\n", ++cas, solve((1<<n) - 1, min(x, y))?"Yes":"No");  
    }   
    return 0;  


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值