HDOJ 题目4455 Substrings(DP)

Substrings

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2592    Accepted Submission(s): 801


Problem Description
XXX has an array of length n. XXX wants to know that, for a given w, what is the sum of the distinct elements’ number in all substrings of length w. For example, the array is { 1 1 2 3 4 4 5 } When w = 3, there are five substrings of length 3. They are (1,1,2),(1,2,3),(2,3,4),(3,4,4),(4,4,5)
The distinct elements’ number of those five substrings are 2,3,3,2,2.
So the sum of the distinct elements’ number should be 2+3+3+2+2 = 12
 

Input
There are several test cases.
Each test case starts with a positive integer n, the array length. The next line consists of n integers a 1,a 2…a n, representing the elements of the array.
Then there is a line with an integer Q, the number of queries. At last Q lines follow, each contains one integer w, the substring length of query. The input data ends with n = 0 For all cases, 0<w<=n<=10 6, 0<=Q<=10 4, 0<= a 1,a 2…a n <=10 6
 

Output
For each test case, your program should output exactly Q lines, the sum of the distinct number in all substrings of length w for each query.
 

Sample Input
  
  
7 1 1 2 3 4 4 5 3 1 2 3 0
 

Sample Output
  
  
7 10 12
 

Source
 

Recommend
We have carefully selected several similar problems for you:   5551  5550  5549  5548  5547 
题目大意:给个n,下边n个数表示这个序列,然后一个q,q个询问,每个询问一个w,问所有长度的w的连续的子序列中不同数的个数和
思路:http://blog.csdn.net/a601025382s/article/details/12283581
ac代码
153681062015-11-03 19:46:04Accepted44551404MS29128K1221 BC++XY_
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define LL long long
using namespace std;
int a[1000100],c[1000100],sum[1000100],num[1000100];
int pre[1000100];
LL dp[1000100];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF,n)
    {
        int i;
        memset(pre,0,sizeof(pre));
        memset(c,0,sizeof(c));
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(i=1;i<=n;i++)
        {
           // scanf("%d",&a[i]);
            c[i-pre[a[i]]]++;
            pre[a[i]]=i;
        }
        sum[n]=c[n];
        for(i=n-1;i>=1;i--)
            sum[i]=sum[i+1]+c[i];
        num[1]=1;
        memset(c,0,sizeof(c));
        c[a[n]]++;
        for(i=2;i<=n;i++)
        {
            if(c[a[n-i+1]]==0)
            {
                num[i]=num[i-1]+1;
                c[a[n-i+1]]=1;
            }
            else
                num[i]=num[i-1];
        }
        dp[1]=n;
        for(i=2;i<=n;i++)
            dp[i]=dp[i-1]-num[i-1]+sum[i];
        int q;
        scanf("%d",&q);
        while(q--)
        {
            int w;
            scanf("%d",&w);
            printf("%lld\n",dp[w]);
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值