HDOJ 题目5100 Chessboard(数学乱搞)

Chessboard

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 857    Accepted Submission(s): 356


Problem Description
Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.
 

Input
There are multiple test cases in the input file.
First line contain the number of cases T ( T10000 ). 
In the next T lines contain T cases , Each case has two integers n and k. ( 1n,k100 )
 

Output
Print the maximum number of chessboard squares tiled.
 

Sample Input
  
  
2 6 3 5 3
 

Sample Output
  
  
36 24
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   5551  5550  5549  5548  5547 
 
题目大意: n*n的棋盘,用kX1的木板覆盖,问最大覆盖的面积
153783252015-11-04 15:52:30Accepted51000MS1732K831 BC++XY_

ac代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        if(m>n)
        {
            printf("0\n");
            continue;
        }
        if(n%m==0)
        {
            printf("%d\n",n*n);
            continue;
        }
        int c;
        c=n>>1;
        if(m<c)
        {
            int i=1,tn=n;
            while(m<(tn>>1))
            {
                tn-=m;
            }
            int k=tn-m;
            int d=min(tn-k-k,k);
           printf("%d\n",n*n-d*d);
        }
        else
        {
            int k=n-m;
            int d=min(n-k-k,k);
                printf("%d\n",n*n-d*d);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值