UVA 题目10739 String to Palindrome(区间DP)

In this problem you are asked to convert a string into a palindrome with minimum number of operations.
The operations are described below:
Here you’d have the ultimate freedom. You are allowed to:
• Add any character at any position
• Remove any character from any position
• Replace any character at any position with another character
Every operation you do on the string would count for a unit cost. You’d have to keep that as low
as possible.
For example, to convert “abccda” you would need at least two operations if we allowed you only to
add characters. But when you have the option to replace any character you can do it with only one
operation. We hope you’d be able to use this feature to your advantage.
Input
The input file contains several test cases. The first line of the input gives you the number of test cases,
T (1 ≤ T ≤ 10). Then T test cases will follow, each in one line. The input for each test case consists
of a string containing lower case letters only. You can safely assume that the length of this string will
not exceed 1000 characters.
Output
For each set of input print the test case number first. Then print the minimum number of characters
needed to turn the given string into a palindrome.
Sample Input
6
tanbirahmed
shahriarmanzoor
monirulhasan
syedmonowarhossain
sadrulhabibchowdhury
mohammadsajjadhossain
Sample Output
Case 1: 5
Case 2: 7
Case 3: 6
Case 4: 8
Case 5: 8

Case 6: 8

题目大意:增加一个字符,删除一个字符,替换一个字符,问让这个字符串编程回文串的最小步数

ac代码

16443982 10739 String to Palindrome Accepted C++11 0.006 2015-11-16 07:04:09
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#define INF 0x3f3f3f3f
using namespace std;
int dp[1010][1010];
char str[1010];
int main()
{
    int t,c=0;
    scanf("%d",&t);
    while(t--)
    {
        int i,j;
        scanf("%s",str+1);
        int len=strlen(str+1);
       /* memset(dp,INF,sizeof(dp));
        for(i=1;i<=len;i++)
            dp[i][i]=0;*/
            memset(dp,0,sizeof(dp));
        for(i=len;i>=1;i--)
        {
            for(j=i+1;j<=len;j++)
            {
                if(str[i]==str[j])
                    dp[i][j]=dp[i+1][j-1];
                else
                    dp[i][j]=min(dp[i+1][j],min(dp[i][j-1],dp[i+1][j-1]))+1;
            }
        }
        printf("Case %d: %d\n",++c,dp[1][len]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值