HDOJ 题目4296 Buildings(贪心)

Buildings

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3006    Accepted Submission(s): 1141


Problem Description
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight w i and strength s i. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σw j)-s i, where (Σw j) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.
 

Input
  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 10 5) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers w i and s i (0 <= w i, s i <= 100000) separated by single spaces.
  Please process until EOF (End Of File).
 

Output
  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
 

Sample Input
  
  
3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
 

Sample Output
  
  
1 0 2
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   4295  4294  4293  4292  4291 
 有n个楼层,每个楼层有一重量w,一个宽度s,每个楼层的损坏值,是他上边的楼层w的和减去他的s,,问你你叠放的最小的楼层损坏值是多少,,,
我特喵读的是楼层的最小的·和,wa了好多次。。。
实际上·还是蛮简单的,a放b上的损坏值b的是a.w-b.s,b放a上a的损坏值b.w-a.s,a.w-b.s<b.w-a.s排就好。。
ac代码
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<stdio.h>
#define LL long long
using namespace std;
struct S
{
    LL w,s;
}b[100550];
int cmp(S a, S b)
{
   return a.w+a.s>b.w+b.s;
}
LL sum[100550];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i,j;
        for(i=1;i<=n;i++)
        {
            scanf("%lld%lld",&b[i].w,&b[i].s);
        }
        sort(b+1,b+n+1,cmp);
        for(i=1;i<=n;i++)
        {
            sum[i]=sum[i-1]+b[i].w;
        }
        LL ans=0;
        for(i=1;i<=n;i++)
        {

            LL temp=sum[n]-sum[i];
            temp-=b[i].s;
            if(temp<0)
                temp=0;
            ans=max(ans,temp);
        }
        printf("%lld\n",ans);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值