POJ 题目2992 Divisors(组合数因子个数)

Divisors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11001 Accepted: 3259

Description

Your task in this problem is to determine the number of divisors of  Cnk. Just for fun -- or do you need any special reason for such a useful computation?

Input

The input consists of several instances. Each instance consists of a single line containing two integers n and k (0 ≤ k ≤ n ≤ 431), separated by a single space.

Output

For each instance, output a line containing exactly one integer -- the number of distinct divisors of  Cnk. For the input instances, this number does not exceed 2 63 - 1.

Sample Input

5 1
6 3
10 4

Sample Output

2
6
16

Source

CTU Open 2005

求c(n,m)的因子个数

判断N!中有几个质因子:P(N!)=N/i+N/i^2+N/i^3+.....N/i^m(i为一个质因子,m是使N/i^m=0的最小值)

ac代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
#define LL long long
using namespace std;
LL pri[83]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53,59,61,67,71,73,79,83,89,97,101,103,107,109,113,127,131,137,139,149,151,157,163,167,173,179,181,191,193,197,199,211,223,227,229,233,239,241,251,257,263,269,271,277,281,283,293,307,311,313,317,331,337,347,349,353,359,367,373,379,383,389,397,401,409,419,421,431};
LL c[432][432];
LL slo(LL n,LL x)
{
    LL ans=0;
    LL sum=x;
    while(n>=sum)
    {
        ans+=n/sum;
        sum*=x;
    }
    return ans;
}
void fun()
{
    LL i,j;
    for(i=1;i<=431;i++)
        for(j=0;j<83;j++)
            c[i][j]=slo(i,pri[j]);
}
int main()
{
    LL n,m;
    fun();
    while(scanf("%lld%lld",&n,&m)!=EOF)
    {
//        LL ans=c[n][m];
        LL ans=1;
        int i;
        for(i=0;i<83&&pri[i]<=n;i++)
        {
            ans*=(c[n][i]-c[n-m][i]-c[m][i]+1);
        }
        printf("%lld\n",ans);
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值