poj 3261 线段树入门

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 38134 Accepted: 17860
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

题目链接:http://poj.org/problem?id=3264

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
#define N 50005
using namespace std;
int num[N];
struct Tree
{
    int l;
    int r;
    int maxn;
    int minn;
}tree[N*4];
void build(int root,int l,int r)
{
    tree[root].l=l;
    tree[root].r=r;
    if(tree[root].l==tree[root].r)
    {
        tree[root].maxn=num[l];
        tree[root].minn=num[l];
        return;
    }
    int mid=(r+l)/2;
    build(root*2,l,mid);
    build(root*2+1,mid+1,r);
    tree[root].maxn=max(tree[root<<1].maxn,tree[root*2+1].maxn);
    tree[root].minn=min(tree[root<<1].minn,tree[root*2+1].minn);
}
int query(int root,int L,int R)
{
    if(L<=tree[root].l&&R>=tree[root].r)
    return tree[root].maxn;
    int mid=(tree[root].l+tree[root].r)/2;
    int ret=0;
    if(L<=mid)
    ret=max(ret,query(root*2,L,R));
    if(R>mid)
    ret=max(ret,query(root*2+1,L,R));
    return ret;
}
int query1(int root,int L,int R)
{
    if(L<=tree[root].l&&R>=tree[root].r)
    return tree[root].minn;
    int mid=(tree[root].l+tree[root].r)/2;
    int ret=100000000;
    if(L<=mid)
    ret=min(ret,query1(root*2,L,R));
    if(R>mid)
    ret=min(ret,query1(root*2+1,L,R));
    return ret;
}
int main()
{
    int n,m,a,b;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
        }
        build(1,1,N);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&a,&b);
            printf("%d\n",query(1,a,b)-query1(1,a,b));
        }
    }

    //cout << "Hello world!" << endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值