HDU BestCoder Round #48 1001

                                         wyh2000 and a string problem

                                         Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Problem Description
Young theoretical computer scientist wyh2000 is teaching young pupils some basic concepts about strings.

A subsequence of a string s is a string that can be derived from s by deleting some characters without changing the order of the remaining characters. You can delete all the characters or none, or only some of the characters.

He also teaches the pupils how to determine if a string is a subsequence of another string. For example, when you are asked to judge whether wyh is a subsequence of some string or not, you just need to find a character w , a y , and an h , so that the w is in front of the y , and the y is in front of the h .

One day a pupil holding a string asks him, "Is wyh a subsequence of this string?"
However, wyh2000 has severe myopia. If there are two or more consecutive character v s, then he would see it as one w . For example, the string vvv will be seen as w , the string vvwvvv will be seen as www , and the string vwvv will be seen as vww .

How would wyh2000 answer this question?
 

Input
The first line of the input contains an integer T(T105) , denoting the number of testcases.

N lines follow, each line contains a string.

Total string length will not exceed 3145728. Strings contain only lowercase letters.

The length of hack input must be no more than 100000.
 

Output
For each string, you should output one line containing one word. Output Yes if wyh2000 would consider wyh as a subsequence of it, or No otherwise.
 

Sample Input
  
  
4 woshiyangli woyeshiyangli vvuuyeh vuvuyeh
 

Sample Output
  
  
No Yes Yes No
水题还会错,唉,刚开始套了三层循环,一直超时,额,不超时才怪。

#include <iostream>
#define maxn 3145728+5
#include <string.h>
#include <stdio.h>
using namespace std;

char c[maxn],a[4]="wyh";
int main()
{
    int n;
    cin>>n;
    int flag;
    while(n--)
    {  // memset(c,0,sizeof(c));
        scanf("%s",c);
        flag=0;
        int cnt=0;
        int len=strlen(c);
        //cout<<len<<endl;
        c[len]='a';
        c[len+1]='\0';
        for(int i=0; i<len; i++)
        {
            if(c[i]=='v'&&c[i+1]=='v')
            c[i]='w';
            if(c[i]==a[cnt])
            cnt++;
            if(cnt==3)
            break;

        }
        if(cnt==3)
        cout<<"Yes"<<endl;
        else
        cout<<"No"<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值