hdu 1698 Just a Hook 线段树区间更新

Just a Hook

                                                                  Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 

题目大意:胖子有个钩子,相当于一个1~n的区间,初始每个点都是1,输入x,y,c,表示把x~y都赋值为c,最后求1~n区间和;

解题思路:线段树区间更新模板;

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1698

代码:

#include <iostream>
#define N 100005
#include <stdio.h>
using namespace std;
struct Tree
{
    int l,r;
    int add;
    long long sum;
}tree[N*4];
void PushUp(int root)
{
    tree[root].sum=tree[root<<1].sum+tree[root<<1|1].sum;
}
void PushDown(int root,int m)
{
    if(tree[root].add)
    {
        tree[root<<1].add=tree[root].add;
        tree[root<<1|1].add=tree[root].add;
        tree[root<<1].sum=(m-(m>>1))*tree[root].add;
        tree[root<<1|1].sum=(m>>1)*tree[root].add;
        tree[root].add=0;
    }
}
void build(int root,int l,int r)
{
    tree[root].l=l;
    tree[root].r=r;
    tree[root].add=0;
    if(tree[root].l==tree[root].r)
    {
        tree[root].sum=1;
        return;
    }
    int mid=(l+r)/2;
    build(root<<1,l,mid);
    build(root<<1|1,mid+1,r);
    PushUp(root);
}
void update(int a,int b,int c,int l,int r,int root)
{
    if(a<=l&&b>=r)
    {
        tree[root].add=c;
        tree[root].sum=(long long)c*(r-l+1);
        return;
    }
    PushDown(root,r-l+1);
    int mid=(l+r)>>1;
    if(mid>=a) update(a,b,c,l,mid,root<<1);
    if(mid<b) update(a,b,c,mid+1,r,root<<1|1);
    PushUp(root);
}
int main()
{
    int t;
    scanf("%d",&t);
    int cas=1;
    while(t--)
    {
        int n;
        scanf("%d",&n);
        build(1,1,n);
        int m;
        scanf("%d",&m);
        while(m--)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            update(a,b,c,1,n,1);
        }
        printf("Case %d: The total value of the hook is %I64d.\n",cas++,tree[1].sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值