hdu 1018 Big Number

Big Number 

题目描述

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

输入

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.

输出

The output contains the number of digits in the factorial of the integers appearing in the input.

样例输入

2
10
20

样例输出

7
19


思路:斯特林公式:lnN!=NlnN-N+0.5*ln(2*N*pi),而N!的位数等于log(N!)+1


#include<stdio.h>
#include<math.h>
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--){
		double s=0;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
			s+=log10(double(i));
		printf("%d\n",(int)s+1);		
	}
	return 0;
}



另一种方法(借鉴他人的代码)

#include<stdio.h>
#include<math.h>
#define p 3.14159265
#define e 2.71828182
int main()
{
	int n,m;
	scanf("%d",&n);
	while(n--){
		double s;
		scanf("%d",&m);
		s=log10(2*p*m)/2+m*log10(m/e);
		printf("%d\n",(int)s+1);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎轩栀海

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值