Max Sum Plus Plus

Max Sum Plus Plus

时间限制: 1000ms
内存限制: 32768KB
HDU       ID:  1024
64位整型:      Java 类名:

    题目描述

    Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

    Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

    Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

    But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^

    输入

    Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
    Process to the end of file.

    输出

    Output the maximal summation described above in one line.

    样例输入

    1 3 1 2 3
    2 6 -1 4 -2 3 -2 3

    样例输出

    6
    8

    提示

    Huge input, scanf and dynamic programming is recommended.

    题的大致意思为给定一个数组,求其分成m个不相交子段和最大值的问题

    设Num为给定数组,n为数组中的元素总数,Status[i][j]表示前i个数在选取第i个数的前提下分成j段的最大值,其中1<=j<=i<=n && j<=m,状态转移方程为:

    Status[i][j]=Max(Status[i-1][j]+Num[i],Max(Status[0][j-1]~Status[i-1][j-1])+Num[i])


    状态dp[i][j]  表示由前j个数,组成i组的和的最大值。

    决策:
    第j个数,是在第包含在第i组里面,还是自己独立成组。
    方程 dp[i][j]=Max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j
    空间复杂度,m未知,n<=1000000,  继续滚动数组。时间复杂度 n^3. n<=1000000.  显然会超时,继续优化。
    max( dp[i-1][k] ) 就是上一组 0....j-1 的最大值,可以在每次计算dp[i][j]的时候记录下前j个的最大值 ,用数组保存下来下次计算的时候可以用,这样时间复杂度为 n^2.



    #include<stdio.h>
    #include<algorithm>
    using namespace std;
    int a[1000003],dp[1000003],y[1000003];
    #define INF 0x3f3f3f3f
    int main()
    {
    	int n,m,maxn;
    	while(~scanf("%d%d",&m,&n)){
    		for(int i=1;i<=n;i++){
    			scanf("%d",&a[i]);
    			dp[i]=0;
    			y[i]=0;
    		}
    		dp[0]=0;
    		y[0]=0;
    		for(int i=1;i<=m;i++){
    			maxn=-INF;
    			for(int j=i;j<=n;j++){
    				dp[j]=max(dp[j-1]+a[j],y[j-1]+a[j]);
    				y[j-1]=maxn;
    				maxn=max(maxn,dp[j]);
    			}
    		}
    		printf("%d\n",maxn);
    	}
    	return 0;
    }


    • 0
      点赞
    • 0
      收藏
      觉得还不错? 一键收藏
    • 打赏
      打赏
    • 0
      评论

    “相关推荐”对你有帮助么?

    • 非常没帮助
    • 没帮助
    • 一般
    • 有帮助
    • 非常有帮助
    提交
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包

    打赏作者

    黎轩栀海

    你的鼓励将是我创作的最大动力

    ¥1 ¥2 ¥4 ¥6 ¥10 ¥20
    扫码支付:¥1
    获取中
    扫码支付

    您的余额不足,请更换扫码支付或充值

    打赏作者

    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值