数字根——Digital Roots

20 篇文章 0 订阅

Digital Roots

时间限制: 1000ms
内存限制: 32768KB
HDU       ID:  1013
64位整型:      Java 类名:

题目描述

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

输出

For each integer in the input, output its digital root on a separate line of the output.

样例输入

24
39
0

样例输出

6
3


#include<stdio.h>
#include<string.h>
char s[10003];
int main()
{
	while(~scanf("%s",s)){
		if(s[0]=='0')	break;
		int num=0;
		for(int i=0;i<strlen(s);i++){
			num+=s[i]-'0';
			if(num>9){
				num=num/10+num%10;
			}
		}
		printf("%d\n",num);
	}
	return 0;
}



常规方法

#include<stdio.h>
#include<string.h>
char s[10003];
int find(int k){
	int d=0;
	while(k>0){
		d+=k%10;
		k/=10;
	}
	return d;
}
int main()
{
	while(~scanf("%s",s)){
		if(s[0]=='0')	break;
		int num=0;
		for(int i=0;i<strlen(s);i++)	num+=s[i]-'0';
		while(num>9){
			num=find(num);
		}
		printf("%d\n",num);
	}
	return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎轩栀海

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值