类似最集合中最大子序列 hdu 2668

Daydream

时间限制: 1000ms
内存限制: 32768KB
HDU       ID:  2668
64位整型:      Java 类名:

题目描述

Welcome to 2009 HDU Girl’s Cup, bless you will happy in it.
Every girl are beautiful if you use you heart to feel. Every corner in the world will colourful and energetic by several girls standing. If you boy, a normal bay, I believe that you will try to watch when a beautiful girl passing you and you will nervous if a girl watching you just when you are watching her.

Now give you a surprise that may be never happy in the real time. Millions of PLMM stand in a line and facing you(^_^). They are dress colourful clothings. You should to find out a maximal subline PLMM that their clothing color are all different.

输入

The input contains multiple test cases.
Each case first give a integer n expressing many many girls stand in line.(n<=10000000)
Next line a string including n character, each character standing one girls’s clothing color.

输出

Output one integer the numbers of maximal subline PLMM that their clothing color are all different and the line's begin and end (based from 0). If their are more answer, print the begin smallest.

样例输入

3
abc
5
aaaba
8
hdugirls

样例输出

3 0 2
2 2 3
8 0 7


n的范围很大,但是经过反复的查看,发现这题和最集合中最大子序列长很象,经过翻看资料,的确

可以用O(n)去做,用一个一维数组就可以了


#include<stdio.h>
#include<string.h>
int a[150];
char s[10000000];
int main()
{
    int n;
    char ch;
    int ben,st,ed,len;
    while(~scanf("%d",&n)){
        ben=st=ed=len=0;
        memset(a,-1,sizeof(a));
        scanf("%s",s);
        for(int i=0;i<n;i++){
            if(a[s[i]] >= ben)     ben=a[s[i]]+1;   //如果发现重复的,回到第一个重复点的下一个位置 
            a[s[i]]=i;
            if(i-ben+1 > len){//如果长度大于原来的长度,起点,终点刷新 
                len=i-ben+1;
                st=ben;
                ed=i;
            }
        }
        printf("%d %d %d\n",len,st,ed);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎轩栀海

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值