poj2253 求生成树的最大边的最小值

/*
描述
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog 
who is sitting on another stone. He plans to visit her, but since the water is dirty and 
full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use 
other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as 
long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is 
defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the
lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
输入
The input will contain one or more test cases. The first line of each test case will 
contain the number of stones n (2<=n<=200). The next n lines each contain two integers
xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is 
Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. 
There's a blank line following each test case. Input is terminated by a value of 
zero (0) for n.
输出
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y"
where x is replaced by the test case number (they are numbered from 1) and y is replaced by
the appropriate real number, printed to three decimals. Put a blank line after each test 
case, even after the last one.
样例输入
2
0 0
3 4

3
17 4
19 4
18 5

0
样例输出
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


思路:建图后,本题求的是在所有从顶点1到顶点2的路径中,使得路径上最大边的权值,最小,求出该权值
容易想多用kurscal算法
*/

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#define N 205

using namespace std;

const double inf = 999999999.0;

typedef struct note {
	int x; int y;
}point;

typedef struct node {
	int u; int v; double w;
}edge;

int n,f[N];
point a[N];
edge e[N*N];
double minjump;

void init()
{
	for (int i = 1; i <= n; i++)
		f[i] = i;
}

int find(int x)//找父节点
{
	if (f[x] == x) return x;
	else return f[x] = find(f[x]);

}

int merge(int x, int y)
{
	int t1, t2;
	t1 = find(x);
	t2 = find(y);
	if (t1 != t2)//根不一样
	{
		f[t2] = t1;
		return 1;
	}
	return 0;
}

int same(int x, int y)
{
	return find(x) == find(y);
}

int cmp(edge a, edge b)
{
	return a.w < b.w;
}

int main()
{
	int cas = 0, vis[N];
	while (scanf("%d", &n) != EOF && n)
	{
		int cnt = 0;
		minjump = 0;
		memset(vis, 0, sizeof(vis));
		for (int i = 1; i <= n; i++)
			scanf("%d%d", &a[i].x, &a[i].y);
		//存储边
		for (int i = 1; i <= n; i++)
		{
			for (int j = i + 1; j <= n; j++)
			{
				e[cnt].u = i;
				e[cnt].v = j;
				e[cnt].w = sqrt(pow(a[i].x - a[j].x, 2) + pow(a[i].y - a[j].y, 2));
				cnt++;
			}
		}
		int m = cnt;//m条边
		sort(e, e + m, cmp);

		init();//初始化集合
		cnt = 0;
		for (int i = 0; i < m; i++)
		{
			if (merge(e[i].u, e[i].v))
			{
				if (minjump < e[i].w)
					minjump = e[i].w;
			}
			if (same(1,2))	break;//当1,2位于同一集合时,说明已找到生成树
		}

		if (cas)	printf("\n");
		printf("Scenario #%d\n", ++cas);
		printf("Frog Distance = %.3lf\n", minjump);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值