素因子分解超快的Pollard_rho算法

C - Aladdin and the Flying Carpet
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: ab(1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2


/**随机数素因子分解法
大数素数判断

*/

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cmath>
using namespace std;
typedef long long LL;
const int Times = 25;
LL factor[100], f[100];
int l, ll, ans, num[100];
LL a, b;

LL gcd(LL a, LL b)
{
	return b ? gcd(b, a%b):a;
}
///(a*b)%n
LL add_mod(LL a, LL b, LL n)
{
    LL ans = 0;
    while(b)
    {
        if(b&1)
            ans = (ans + a)%n;
        b >>= 1;
        a = (a<<1)%n;
    }
    return ans;
}
///a^m%n
LL pow_mod(LL a, LL m, LL n)
{
    LL ans = 1;
    while(m)
    {
        if(m&1)
            ans = add_mod(ans, a, n);
        m >>= 1;
        a = add_mod(a, a, n);
    }
    return ans;
}
///以a为基,n-1=x*2^t      a^(n-1)=1(mod n)  验证n是不是合数
///一定是合数返回true,不一定返回false
bool Witness(LL a, LL n)
{
    int j = 0;
    LL m = n-1;
    while(!(m&1))
    {
        j++;
        m >>= 1;
    }
    LL x = pow_mod(a, m, n);
    if(x == 1 || x == n-1)
        return true;
    while(j--)
    {
        x = add_mod(x, x, n);
        if(x == n-1)
            return true;
    }
    return false;
}
///判定是否是素数
bool Miller_Rabin(LL n)
{
    if(n < 2)
        return false;
    if(n == 2)
        return true;
    if(!(n&1))
        return false;
    for(int i = 0; i < Times; i++)
    {
        LL a = rand()%(n-1)+1;
        if(!Witness(a, n))
            return false;
    }
    return true;
}
///关键算法 Pollard_rho 算法,求解素因子
LL Pollard_rho(LL n, LL c)
{
	LL i = 1, x = rand()%(n-1)+1, y = x, k = 2, d;
	//srand(time(NULL));
	while(true)
	{
		i++;
		x = (add_mod(x,x,n)+c)%n;
		d = gcd(y-x,n);
		if(d > 1 && d < n)
			return d;
		if(y == x)
			return n;
		if(i == k)
		{
			y = x;
			k <<= 1;
		}
	}
}
///对n进行素因子分解
void get_fact(LL n, LL k)
{
	if(n == 1)
		return;
	if(Miller_Rabin(n))///是素数
	{
		factor[l++] = n;
		return;
	}
	LL p = n;
	while(p >= n)
	{
		p = Pollard_rho(p, k--);
	}
	get_fact(p, k);
	get_fact(n/p, k);
}
///得到指数num[]
void get_num()
{
    sort(factor, factor+l);
		/**for(int i=0;i<l;i++)
            cout<<factor[i]<<" ";
        cout<<endl;*/
		f[0] = factor[0];
		num[0] = 1;
		ll = 1;
		for(int i = 1; i < l; i++)
		{
			if(factor[i] != factor[i-1])
			{
				ll++;
				f[ll-1] = factor[i];
				num[ll-1] = 0;
			}
			num[ll-1]++;
		}
}
///搜索查找 适合的值
void dfs(LL x, int p, LL m)
{
	if(x > m)
		return;
	if(p == ll)
	{
		if(x >= b && a/x > x)
			ans++;
		//printf("%lld\n", x);
		return;
	}
	LL y = 1;
	for(int i = 0; i <= num[p]; i++)
	{
		dfs(x*y, p+1, m);
		y *= f[p];
	}
}
int main()
{
	int cas = 1;
	int T;
	scanf("%d", &T);
	while(T--)
	{

		scanf("%lld %lld", &a, &b);
		LL m = sqrt(a+0.5);
		ans = 0;
		l = 0;
		get_fact(a, 120);
        get_num();
		//for(int i = 0; i < ll; i++)
		//	printf("%lld %d\n", f[i], num[i]);
		dfs(1, 0, m);
		printf("Case %d: %d\n", cas++, ans);
	}
	return 0;
}


  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值