light oj 1031

C - Easy Game
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

You are playing a two player game. Initially there are n integer numbers in an array and player A and B get chance to take them alternatively. Each player can take one or more numbers from the left or right end of the array but cannot take from both ends at a time. He can take as many consecutive numbers as he wants during his time. The game ends when all numbers are taken from the array by the players. The point of each player is calculated by the summation of the numbers, which he has taken. Each player tries to achieve more points from other. If both players play optimally and player A starts the game then how much more point can player A get than player B?

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the size of the array. The next line contains N space separated integers. You may assume that no number will contain more than 4 digits.

Output

For each test case, print the case number and the maximum difference that the first player obtained after playing this game optimally.

Sample Input

2

 

4

4 -10 -20 7

 

4

1 2 3 4

Sample Output

Case 1: 7

Case 2: 10

题意:有一个序列,A和B两个人可以从两端取数,每个人至少取一个数 ,至多取完所有数,A先取,问最后A取得的数的和比B取得的数的和最大大多少;

区间dp,dp[ i ][  j  ] 表示取完区间 i 到 j A取得的数之和比B取得的数之和最多多少, dp[ i ][ j ] = max( dp[ i ] [ j ] , max((sum[k]-sum[i-1]-dp[k+1][j],sum[j]-sum[k]-dp[i][k] )


#include <iostream>
#include <string.h>
using namespace std;
const int maxn=105,inf=0x3f3f3f3f;
int a[maxn],sum[maxn],dp[maxn][maxn];
int main()
{
    int t,T=0,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        memset(dp,-0x3f,sizeof(dp));
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            cin>>dp[i][i];
            sum[i]=sum[i-1]+dp[i][i];
        }
        for(int i=n-1;i>=1;i--)
        {
            for(int j=i+1;j<=n;j++)
            {
                for(int k=i;k<=j;k++)
                {
                    if(k==j)
                    {
                         dp[i][j]=max(dp[i][j],sum[j]-sum[i-1]);
                         continue;
                    }

                    else
                    {
                        dp[i][j]=max(dp[i][j],max(sum[k]-sum[i-1]-dp[k+1][j],sum[j]-sum[k]-dp[i][k] ) );
                    }
                }
            }
        }
        cout<<"Case "<<++T<<": "<<dp[1][n]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值