hdu4738 双向边求桥

Caocao's Bridges

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3876    Accepted Submission(s): 1223


Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
 

Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.
 

Sample Input
  
  
3 3 1 2 7 2 3 4 3 1 4 3 2 1 2 7 2 3 4 0 0
 

Sample Output
  
  
-1 4
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5877  5874  5873  5872  5871 


曹操要攻打刘备,在长江的岛屿之间建立了一些桥,刘备为了破坏曹操的联通桥,派人去炸桥,但是他只有一枚炸弹,曹操的桥上有士兵,刘备必须派大于等于桥上的士兵数量的士兵去炸桥,如果能使曹操的桥不在联通输出最少派的士兵,否则输出-1

有三个坑 1,可能有重边   2 , 有多个联通图时输出0,有士兵数为0的桥输出1


AC 代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <set>

using namespace std;
const int maxn=1e6+10,inf=0x3f3f3f3f;
struct Edge
{
    int to,next,cap;
    bool cut;
}edge[maxn*2];
int tot,head[maxn];
int bridge, Index,top;
int Low[maxn],DFN[maxn];
bool cut[maxn];
int add_bolck[maxn];
set<int>s;
void init()
{
    tot=0;
    memset(head,-1,sizeof(head));
    s.clear();
}
void add_edge(int u,int v,int cap)
{
    edge[tot].to=v;
    edge[tot].cut=false;
    edge[tot].next=head[u];
    edge[tot].cap=cap;
    head[u]=tot++;

}
void Tarjan(int u,int pre)
{
    int v;
    Low[u]=DFN[u]=++Index;
    int son=0;
    int pre_num=0;///判断重边
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        v=edge[i].to;
        if(v==pre&&pre_num==0)
        {
            pre_num++;
            continue;
        }

        if(!DFN[v])
        {
            son++;
            Tarjan(v,u);
            if(Low[u]>Low[v])
                Low[u]=Low[v];
            if(Low[v]>DFN[u])
            {
                bridge++;
                edge[i].cut=true;
                edge[i^1].cut=true;
                s.insert(edge[i].cap);
            }
        }
        else if(Low[u]>DFN[v])
            Low[u]=DFN[v];
    }
    if(u==pre&&son>1)cut[u]=true;
    if(u==pre)add_bolck[u]=son-1;
}
void solve(int n)
{
    memset(DFN,0,sizeof(DFN));
    memset(add_bolck,0,sizeof(add_bolck));
    memset(cut,false,sizeof(cut));
    Index=0;
    top=0;
    bridge=0;
    int num_G=0;
    for(int i=1;i<=n;i++)
    {
        if(!DFN[i])
        {
            num_G++;///连通图个数
             Tarjan(i,i);
        }


    }
    if(num_G>=2)
    {
        printf("0\n");
        return;
    }
    if(bridge==0)
        printf("-1\n");
    else
    {
        set<int>::iterator it;
        it=s.begin();
        int out_ans=*it;
        if(out_ans==0)
        out_ans=1;

        printf("%d\n",out_ans);
    }
}

int main()
{
    int n,m;
    int u,v,w;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        init();
        if(n==0&&m==0)
            break;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);

            add_edge(u,v,w);
            add_edge(v,u,w);
        }

        solve(n);

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值