JAVA大数处理(BigInteger,BigDecimal)

在做acm时,发现很多东西其实在java中是不用自己实现的,比如说java 的大数处理。如果要自己实现,浪费时间~。

JAVA中有两个类BigIntegerBigDecimal分别表示大整数类和大浮点数类,至于两个类的对象能表示最大范围理论上能够表示无线大的数,只要计算机内存足够大。

这两个类都在java.math.*包中,因此每次必须在开头处引用该包。

 

Ⅰ基本函数:

1.valueOf(parament); 将参数转换为制定的类型

   比如 int a=3;

       BigInteger b=BigInteger.valueOf(a);

     则b=3;

         String s=”12345”;

       BigInteger c=BigInteger.valueOf(s);

       则c=12345;

 

2.add(); 大整数相加

   BigInteger a=new BigInteger(“23”);

   BigInteger b=new BigInteger(“34”);

a.      add(b);

 

3.subtract(); 相减

4.multiply(); 相乘

5.divide();    相除取整

6.remainder(); 取余,符号和原数相同.

7.pow();   a.pow(b)=a^b

8.gcd();   最大公约数

9.abs(); 绝对值

10.negate(); 取反数

11.mod(); a.mod(b)=a%b=a.remainder(b);这个似乎是取得正余数.

12.max(); min();

13:compareTo(); 根据该数值是小于、等于、或大于 val 返回 -1、0 或 1;

14.boolean equals(); 是否相等

15.BigInteger构造函数:

   一般用到以下两种:

   BigInteger(String val);

将指定字符串转换为十进制表示形式;

   BigInteger(String val,int radix);

将指定基数的 BigInteger 的字符串表示形式转换为 BigInteger

.基本常量:

   A=BigInteger.ONE    1

B=BigInteger.TEN    10

C=BigInteger.ZERO   0

Ⅲ.基本操作

1.   读入:

用Scanner类定义对象进行控制台读入,Scanner类在java.util.*包中

Scanner cin=new Scanner(System.in);// 读入

while(cin.hasNext())   //等同于!=EOF

{

   int n;

   BigInteger m;

   n=cin.nextInt(); //读入一个int;

   m=cin.BigInteger();//读入一个BigInteger;

System.out.print(m.toString());

}

Ⅳ.运用

个位数统计

给定一个k位整数N = dk-1*10k-1 + ... + d1*101 + d0 (0<=di<=9, i=0,...,k-1, dk-1>0),请编写程序统计每种不同的个位数字出现的次数。例如:给定N = 100311,则有2个0,3个1,和1个3。

输入格式:

每个输入包含1个测试用例,即一个不超过1000位的正整数N。

输出格式:

对N中每一种不同的个位数字,以D:M的格式在一行中输出该位数字D及其在N中出现的次数M。要求按D的升序输出。

输入样例:
100311
输出样例:
0:2
1:3
3:1


import java.math.BigInteger;
import java.util.Scanner;

public class Main {
 public static void main(String[] args) {
  Scanner scan = new Scanner(System.in);

  
  BigInteger num = scan.nextBigInteger();
  int k[] = new int[10];
  
  while(0!=num.compareTo(BigInteger.valueOf(0))){
   int t = num.remainder(BigInteger.valueOf(10)).intValue();
   k[t]++;
   num = num.divide(BigInteger.valueOf(10));
  }
  for(int i = 0;i<10;i++){
   if(k[i]>0){
    System.out.println(i+":"+k[i]);
   }
  }
 }
 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值